WDTV Live Hub and Apple Time Capsule Internet Problems


 I had my WDTV Live Hub working fine with my Netgear WNDR 3700 via LAN cable.  My wife just bought me a 2 TB Time Capsule as an early Christmass gift and I cant get the WDTV to pull an IP from the TC.  I even tried manually placing the IP address, subnet, gateway, dns.  Bottom line is that I continue to get a DNS error whenever I try to run the Check Connection.  I do get a green check mark on the IP address but red x’s for DNS and Internet Connection.  

My address is set up as follows:





I have changed these in the airport utility from the Apple Standard 10.0.1.x.  If I plug my Macbook Pro directly to the same cable I get an IP address instantly with full connectivity.  As I stated before, I was up and running with the Netgear, so it is obviously a Time Capsule issue.  I have also tried putting comcast DNS address and some OpenDNS ones directly with no luck.

Any ideas?

I like Apple products, but they are really hard to work with them if you are not using another Apple device. As per your post, you have done most of the basic troubleshooting, why don’t you try to contact Apple tech support?

  Could not figure it out.  So I went ahead and put my Netgear back in the network as the main router.  I am now using the Time Capsule in bridge mode in a different room.  No problems in this set up at all and I am able to do back ups to my TC with Time Machine.