WDTV Live has frozen 6 times in 2 days (about 4 hours of play)


#1

As the title says, my WDTV player has frozen 6 times in the past 2 days. Each time it freezes, I have to completely reboot the system, losing my place in whatever I was watching.

Am I just unlucky, or is anyone else experiencing frequent freezes as well?

I was satisfied with this player, but its looking more and more like a shoddy product. I’m tempted to return it while I can.


#2

Your message is vague, if you want help you will need to be specific. How are you connected? Are you using wired? wireless? USB?

There are many threads on this forum covering many issues. I would suggest you read them and find one that matches your situation and go from there. :smiley:


#3

I actually didn’t think a solution was available, I was kind of venting. And I actually did search this (and other forums) using keywords such as “freezing”, without a solution applicable to me. However, if a solution is available, here is some more information:

I am connected to a network via a wireless card, and I am streaming media from my computer. The files I am playing are mostly standard avi divx format. When the system freezes, I have to unplug the system and inititate a hard reboot. I have also frozen a few times while playing YouTube content.


#4

Palex1980 wrote:

 

Am I just unlucky, or is anyone else experiencing frequent freezes as well?

 

I was satisfied with this player, but its looking more and more like a shoddy product. I’m tempted to return it while I can.

 

I’ve only had one freeze since getting mine a couple of weeks ago.

Left it idle for a long time with the screen saver running (well over an hour) and when I came back and tried to navigate the shares it simply froze.  

Had to power cycle and then it worked fine.  Like I said, just happened one time.

The product seems poorly equipped to handle errors or unexpected input of any kind.  Like my example, I guess the share wasn’t immediately available and it just freaked out.  Then there’s the YouTube issue, where the login API has changed and instead of coming back with a sensible error message the unit reboots.  Genius.  :|


#5

I can identify with the whole venting thing. : )

I would try other ways of getting those files. If you have a usb hard drive flash, drive, or wired network, try watching your files one of those ways. If those don’t 'freeze" it would be reasonable to think the issue is the wireless connection.  I tried wireless with mine and it was very flakey. I started using wired but then had issues with it dissconnecting. I read the suggestions in the threads here, tried them and it seems to be mostly working. I rarely get disconnected. I am hoping that will get sorted out as the firmware matures. I am also hoping that Western Digital is commited to this product and will work out the bugs.

I have no idea of your technical abilites other than you know enough to find this forum. : ) With what I have experienced with this and a couple of similar devices, they are certainly not “plug and play”. At this point you have to pretty much learn more than you want to about them or just wait until they mature and you won’t need to. 


#6

I don’t know whether this will help you but it worked for me.

I had a problem since last night with freezing and not being able to turn the unit off.

I run my files off an external hard drive and I swapped the drive over this afternoon and everything started playing again.

When I went to delete the .wd_tv folder that has been placed by the unit on the hard drive I got the message “cannot delete ph.db-journal: The file or directory is corrupted and unreadable”

I had to run the check disk on start up on the computer for it to delete the files and once I plugged the hard drive back into the unit, it replaced the file back on the hard drive and now it works perfectly.

Hopefully you might just have a corrupted .wd_tv folder too.


#7

Well, it’s been a couple weeks since I posted this, and the freezing problem… HAS GOTTEN WORSE. It now freezes at least 2 times per night. So we’re looking at 30+ freezes since I posted this. The patch has solved nothing. I’m using one of the recommended wireless cards. I’ve tried every suggestion thrown at me.

Beyond that, why isn’t there a simple reset button? Why do I have to unplug the thing completely to reboot it? Jesus Christ.

I’m embarrassed that I bought one of these as a gift for my brother. I soooo wanted this to work out.


#8

I’ve purchased this unit just a few days before christmas, I was disappointed at first at the quality but with recent firmware things are very good now.  I have played hours and hours and hours of stuff with this unit and not a single problem.  I do think however the unit is not properly cooled.   The unit uses a passive heatsink on the chipset, which can btw, get quite hot after a while.  Without a fan to get that hot air out of the unit, it’s useless.  I’m thinking perhaps the freezing issues people are having are probably due to overheating (placing the unit in a closed area inside a wall unit for example.   Make sure you do not place the unit in a closed area that does nto have proper air flow. 

For those having freezing problems try placing the unit in an open area with enough airflow around the unit.

Try using one of those small fans blowing air on the unit itself, see if this helps.

That huge heatsink sitting on the chip is useless if it gets hot and it is not cooled.  Why the hell didn’t they add a fan on the reference design - fans nowadays are very quiet.

Normally you don’t need a fan with this unit with normal room temperature and enough air flow, but if your room is very hot during hot summer months, the unit will get very hot.


#9

While, I have not experienced “freezes”.  I have noted some sound break up when playing AC3 sound embedded in mkv files and also a DVD file.

This happened after the unit was turned on for some time, was playing mp3 music then switched over to some movie files. Some played Ok but others played with sound break up at intermittant time frames.  Note: the audio bit rate on these would be higher and one was a HD video as well …so probably needing heavy CPU.

Note also, very warm here,  summer time in Aus  …35 C

I turned the unit off  via remote…  Waited a few mins, then turned it back on and the two files that had problems before …now played without any issue. 

Hmmm …I had, mounted the unit inside a cabinet, but with 4" or so of space above and reasonable air flow, I thought. The unit was sitting horizontal (not vertically - up and down) and on top of other Hi-Fi units that do get warm as well.

I moved it to outside of the cabinet and to a vertical standing position.

Note: given that the air slots are on each side, having the unit standing vertically would help air flow.

Now everything is working without any problems. 

So the unit is very sensitive to heat and requires good airflow.


#10

well mine freezes about 6 times an hour.  I’m not sure if this is the problem you are experiencing but with my original unit (and with the replacement unit that i now have) what happens to me, is this:

     When i am watching a video, whether through the wired network (wired to a NAS and  a share on a PC) or on the local usb drive, i can fast forward a few times but eventually i will click fast forward and get a message that says “unable to play the selected file, (the one that’s been playing just fine all along) please check supported formats”.  Then i click ok and the video resumes but it has the “waiting” circle spinning right in the middle and i cant fast forward/rev… nor stop… nor next.  I can click the back button and go to the thumbnails menu, but when i do i still hear the audio playing and i cant start another video. i can only go back to the same video thats playing and of course it contunues playing with the circle spinning and i am unable to do anything.  I must power cycle the unit to get it to play again.

       Also occasionally when i fast forward… it will give me the unable to play message… then it will resume when i click ok but it resumes in fast forward mode without me being able to resume normal play.

       I read on another unofficial board of many others having this problem and there is some homebrew firmware where people are able to telnet into the unit and stop a couple of processes (namely DMARender and PICRender) to get the circle to go away and resume playing but i am not about to go putting software im not familiar with in my device, though at this point im tempted since im about to throw it through the wall anyway. maybe the programmers at WD could look into the process thing. it would be appreciated because im very disappointed with the product at this point.


#11

My Live unit also freezes/locks up regularly when watching video files.  Its done it since day one (the first day Best Buy had them in stock).  I only use an external WD Passport drive or USB key to connect up the unit.

Its not the file that causes lockups because after a reboot I can fast forward to a minute before where the freeze occurred and it will play on through.

I guess it could be related to temperature at the box gets pretty warm but still, in my case its on the top of a cabinet with no other components anywhere near the thing.  It should not be doing this.

Last night was the final straw, 3 lock-ups whilst watching a 50 minute video.  It needs to be taken back to the shop for a replacement…

And finally I had one of the first non “live” versions of this product and it gave me no problems. 

Maybe my Live unit is a dud?


#12

Hello,

I would like to know if you found a solution or workaround for this issue. Do you know the cause? may it be related to some firmware version or video codec?

I noticed this after upgrading to current firmware ( 1.02.21 ), but for a couple of months it  disapeared. Now it is happening again and very often (every 2 movies I try to play I have to reboot the device).

I will appreciate any assistance with this.

Best regards,

Federico


#13

Hi, sorry but I never found a resolution to this.


#14

Thanks for your answer. I just opened a case with WD for that, let’s see if they can help.

Regards,

Federico


#15

MY WDTV  LIVE PLUS freezes too. I thought i have a defective remote control. I got the replacement remote control from WD but the same problem happened… Did some  testing and found out that this WDTV Live Plus will freeze if a wireless OR wired ethernet  plus  PASSPORT ELITE are connected at the same time… 

If i have the Buffalo MIni USB Wireless Adapter connected to USB2 and  NO USB Drives it worked flawlessly…

BUT if connect my PASSPORT ELITE to USB1 plus the BUFALLO MINI  WIRELESS at USB2 , the unit freezes…

Same thing happened to a WIRED Ethernet Connection…  They can not coexist in my unit…

If its ONLY PASSPORT ELITE and NO WIRELEES or WIRED NETWORK,  the unit plays flawlessly again…

The Firmware is the latest for WDTV live PLUS…

Any Solution ?


#16

Hi,

I am not using a WiFi adapter nor USB device, just ethernet and a My Book 1Tb NAS.

I found the problem disappeared when I downgraded to previous firmware. On the other hand support team answered that the cause of the processor to be overloaded and that it might be fix by resetting the device using the small hole in the top (or lateral depending on your arrangement). I was a little skeptic on how resetting the device will solve the overload issue, but they answered that after long usage the device get overloaded and resetting might help. I did not try this yet because I am still with the previous firmware. I am planning to upgrade one of there days and eventually will try this.

Good luck!

Federico


#17

Gregvolt - THANK YOU - I have exactly the same problem. Have gone through 5 different players and returned them all for the same reason

using WD External hard drives connected via USB…formatted Mac HFS; they will start to hang on a file (with that spinning blue wheel going around) and the only way to stop it is by pulling out the power and restarting.

I’m thinking maybe it has to do with the volumes being journalled. Anyone having this problem with HSF formatted drives? I’ve called WD and they have no solution. I asked the tech for a firmware fix but he had no knowledge of this being an issue…At least now I know it’s not just me…


#18

mine wasnt hfs formatted and it happened to me constantly. ive resigned the WD to my 2nd tv that i rarely watch and bought a brite-view cinematube. works flawlessly off my shares and has “go to” function with a numeric keypad on the remote… but no thumbnail preview capability for movies. thats ok… at least i can watch them.

      Incidentally the WD player was the 2nd one to do the same thing after an RMA with WD.

    A note to western digital: keep working on that youtube function and dont worry about movies freezing! because lord knows we all love to take 2 minutes to punch in a search query to watch a 38 second video. its much more efficient on the wd live player than to use the keyboard on my pc.


#19

8ball2001 wrote:

 

That huge heatsink sitting on the chip is useless if it gets hot and it is not cooled.  Why the hell didn’t they add a fan on the reference design - fans nowadays are very quiet.

 

Normally you don’t need a fan with this unit with normal room temperature and enough air flow, but if your room is very hot during hot summer months, the unit will get very hot.

 

 

One of the reasons I bought the WDTV live is because it was fanless ! I hate fans, even my pc doesnt have fans (i have a fanless power supply in it, fanless cpu cooler and fanless videocard. Ok, the case has 1 fan). And I live in the caribbean, and both my pc and WDTV Live never crash/freeze. Oh and the PC’s cpu is overlocked to 4 ghz :wink:

Not sure what the problem is here,cyberoprh said he returned 5 different WDTV’s who all were freezing ? That seems like something’s wrong in the setup instead of the player. Did you place it on a solid surface ?


#20

cyberorph wrote:

…formatted Mac HFS

First thing I’d try is to change that to another drive, FAT32 or NTFS for example. Did you also try network streaming ?

Also, chances are that this will fix your problem:  http://www.cgsecurity.org/wiki/TestDisk