WDTV Live freezes OSD and remote is no longer responding


I play all my movies via a network share.

When I start a movie (tried dozens different, with different codecs) the normal OSD appears on screen, but stays there forever while the movie is playing. The OSD does not increment the time and does not move its slider. It just stays at 00:00 all the time. At the same time, the remote control is not responding anymore. The only way to get control of the unit is to remove the power and plug it again.

I have the latest firmware. The unit is new. It played well for a week.

I reset it to factory defaults, without solving the issue.

My network share is a linux running samba. I tried with login and guest configs. Same issue.

Any ideas?

I have the same problem. I had to rollback to older firmware.

I’m having a similar problem with one of my units.

Running the latest firmware, the OSD stays on screen and doesn’t update.  If I press enter when it first appears, the OSD disappears, but the unit doesn’t respond to the remote any more.  After I power the box off and back on, it does the same as soon as a video plays.

I rolled back the firmware and the problem went away.  Tried going forward to the latest firmware again and the problem was back.  The trouble is, if I revert the firmware back again, it constantly prompts to update to the latest firmware and sooner or later either my Wife or Son are going to update it accidentally.  Is there any way to stop the firmware from prompting to update constantly (without removing the network cable, as all our films are stored on network drives)?

Same here. Really frustrating. Downgrading to firmware 1.3.49.V worked fine for me but now I have the resolution problem.

Smoking will kill you, so does WD TV Live.

I have the same problem with one of my WDTV Live. The strange thing about it is that it worked fine for about two months.

Has anyone tried to contact WD support about this?