WDTV live does not see Seagate freeagent home 2tb via router


Just bought an external HDD, freeagent goflex Home Seagate 2tb, but the wdtv live does not see it.

I connect everything via a router Lynksys with Ethernet cable.


Have you checked the permissions to make sure the user called “everyone” has read access?

Are all the devices in the same workgroup?

Yes all the devices are in the same workgroup.

Anyway I figured it out.

Thanks for you help

It’d be helpful if you post your solution in case it helps other people…

What was the problem?, I have 7 drives and nothing comes up on WD.

I was not able to see the HDD, network or USB…

Now its working fine…

What you can do is to click on the red button when you are in the video file:

When you turn on the WDTV, click on video you should have the folder WDTV… when you are here click the red button on the remote control, you will be ask to choose the hard HDD local or USB or on the network.

That is what I did, it is simple but if nobody tell you what to do…

Let me know if it is working.

Uhm…   That’s only applicable to the WDTV Live HUB, Not the Live / Live+, which is the forum this was in…