WDTV Live displaying "The content source has been removed"

Kudos to anyone that can resolve this issue…

This network consists of 3 x WDTV live streaming players and 1 x WDTV 1TB Live Hub.  The live hub is connected to a wireless router/access point with a cat 5 cable and the 2 media players are connected wirelessly.  We are getting random errors on all three of the media boxes saying “the content source has been removed”. This may happen when you first access the box, in the middle of a movie, end of a movie of when you are simply browsing the folders to select media.  Restarting the media players does not help but a restart of the main live hub sorts the issue for perhaps 12-24 hours and then the issue starts again.  All devices are using the latest firmware and the wireless signal is strong as when it is restarted and working, we can stream to all 3 media players simultaneously with no stuttering or issues. The SSIDER software program tells me that the wireless channel is away from other wireless channels in the area.  I would estimate that 90% of the time only 1 player is being used but when the issue arises, it affects all WD Live players.  I have done the following troubleshooting.

  1. Set static IP addresses on all WD devices.

  2. Change the channel on the wireless router to one away from other wireless access points in the area…

  3. Upgrade the firmware on the Linksys WAG200G router.

  4. Change the router to another model and manufactuter. (Belkin top of their range model)

  5. Reset the Live hub back to factory defaults and reconfigure.

  6. Reset the WDTV live boxes back to factory default and reconfigure.

  7. Swap the router/access point for one I have been using in our office which works perfectly.

  8. Turn off all unnecessary services on all boxes.

My next test will be to put in a standard wired network switch and directly cable the WDTV Live boxes to it and see what happens over a 48 hour period.  All other devices on the network, wired and wireless work fine with no disconnection issues.

Any help appreciated and I have invested a lot of time and money into this setup.


Try doing a roll back to a previous firmware version and check if the same problem happens. Check the link below. 


Is your “Content Source” the Hub? Are you streaming from Twonky on the Hub? Check your Twonky config - Under “Network”  -uncheck “Restart on NIC changes” and see if that helps. (This is assuming Twonky on the Hub has this setting)

I don’t have a Hub, but have 2 x TV Live, and 2 x Mybook on my network - Updated firmware on the Mybook live (which included a Twonky update) and started having the exact probelm you are reporting. I decided it was something in Twonky since it happened no matter what TV Live I used (they are different models) and I didn’t have the same issue with my older Mybook (World Edition - older version of Twonky)

I looked for differences in the Twonky setup and this checkbox seemed the obvious culprit - made the change two weeks ago and haven’t had a ‘removed’ message since.

Hope it helps

Thanks Alucardx23.  I will give this a go over the weekend and report back. (The units are at my sisters house) One of my passwords for a good while was Alucard. (Dracula backwards).  The history with this is as follows:  I have purchased about 8 of these WDTV live units over the past 6 months and gave 5 away to family.  I have had trouble with all of them at this point.  My brother had a strange problem with the WDTV live box randomly reporting “Fatal error”.  To make a VERY long troubleshooting story short. it turned out to be his cheap HDMI cable.  Replaced the cable to the TV and the issue was resolved. Just shows you cant exclude any item from the troubleshooting!  I still have the problem with the units at mu sisters house and yesterday evening my own WDTV live stopped accessing my WDTV media hub immediately after I updated the firmware from 1.11.14 to 1.12.14 saying “cannot access content source”.  I reset the unit and went through the setup again but no success.  This unit has worked PERFECTLY since I got it about 9 months ago.  Thankfully I only updated one of my 3 WDTV live boxes and not them all.

WD are introducing more problems than they are fixing with these updates.  I am in the process of downloading the 1.11.14 firmware to roll back my unit and then I will download the older firmware for my sisters units. I have told family to turn off automatic firmware updates as I just dont need the hassle. Plus my family members are only using the units to stream movies from a HDD and dont use or need any of the new online stuff being added to the unit.  I am familiar with troubleshooting stuff as I am an IT engineer and do it every day.  This has been a lot of hassle for me trying to get the units working consistently especially considering I gave the units away as gifts. 

Anyway, thanks for your help, I will report back with my progress.


Hi Christyguy,

Thanks for your post.  No twonky in the setup. Just WDTV Live boxes connecting to a WDTV media hub.  Only thing being accessed is movies, no other online stuff.


Hi Alucardx23,

An update as promised. I rolled back the firmware to 1.11.14 and all is back to normal with my WDTV live box.  This is the issue that only started yesterday with the new firmware.  I am really pissed off with WD.  Its a great product but they are turning it into a nightmare with these firmware updates.

Note for other users rolling back. The update said it was 2.11.14 and not 1.11.14.  This may be by design but there was no mention of this on the download page.

I will tackle my sisters WDTV live boxes over the weekend.


Edited to amend typos.

The 2.11.14 bit is by design as it is the only way to fool the player into rolling back the firmware.

I had this issue when streaming internet based content.  Ultimately what seemed to have worked is my disabling of the QOS engine in my router config, however, I also reserved an IP address for my WDTV Live.  The reason I point to the QOS engine is because I’ve seen some users report static/reserved IP’s not making a difference in this issue.  I hope this helps.  I nearly returned the box because of this, but it looks like everything’s going to be ok at this point. :smileyvery-happy:

Following up to say my initial solution has turned out not to be so.  The problem returned last night unfortunately.  Pushing ahead…