WDTV Live and Bell Fibre Home Hub 2000

I recently upgraded my internet, and with that got a new Modem/Router.  The modem is a SageMcom Fast 5250 Home Hub 2000.  It has two USB ports on the side for network storage.  Awesome.

I plugged my 1TB hard drive into the modem and all my connected devices can now access the media on it no problem except for the WDTV Live.  The WD can’t see the share at all.

The drive is supposed to be shard as \mynetwork and my other devices can see that.  The drive is also supposed to be accessable via DLNA, and the other computers can see that as well.  The WD sees that there’s a DLNA share, but when trying to access it, the list of media files comes up blank.

Does anyone have a solution to this problem?

I apprecieate any help.



Hi, what protocol is the 5250 using to share the files over the network? Have you verified if the DLNA content is visible from other devices? 

No clue what protocol the 5250 is using, I tried contacting their support people but they’re pretty quiet. (that’s why my reply took so long) :frowning:

My other devices are all Windows 7 or Android, except for the blu-ray player, not sure what that’s using either, but it works.


I am wondering if anyone has found an answer to this solution, Bell is no help at all.  I hooked my external drive ( WD mybook 4tb) up to the home hub (installed today) and I can see it in the router settings when I log into thr 192… site but it says it is “not connected”  repeated attempts have have no diiference and I cant locate it on any computer in the house.  I plug a small USB stick into it and it works.  the only difference (I believe) is the format of the drives, small stick is a FAT32 and the larger drive is NFTS.  I did find one post that says all drives would have to be in FAT32 to work…I am hoping not… I love any help of fixes out there!!  thanks

Hi, did you find any solution? I just bought the my book 4Tb to connect it to my bell hub 2000?

But don’t want to opened if don’t work. Please let me know any update


I’m having this exact problem after changing to the Bell Fibe Router. When my Passport was connected to my Belkin Router there was no problem, but now it does not see the "Media’ Files.

I also checked apparently my passport is also NTFS. I have another WD Drive that I will format as FAT 32 and see if that makes a difference.

Have you found any other solution?

I just recieved the hub 2000 and wanted to plug in my 2tb harddrive into it. I could not locate it on my PC as well. Followed all the bell tutorials and called with no luck. if anyone has found the solution it would be helpful… My external is formated in NTFS as well

Hi, I have the same issue, I had a my book live that was ethernet, worked fine until it went dead… 

I bought a my book USB and hooked it up to the Bell Modem. 

My computers can see it, but the WD media player can’t see it. 

I see the Bell media hub as an option but with no files. Hope someone finds a solution. 

I know it has been a while, but I am having the same issue with my WD My Book 3TB & connecting to the Bell Home Hub USB. The router login sees the USB device, but I can’t mark it as shareable (no settings on the USB device in the router app). When I follow the instructions from Bell (Windows 7 - lol) it doesn’t see the device in file explorer.

Does anyone have an idea to try, I really wanted this on my network.


Wow this has been opened for a while and still no solution. I have the Home hub 3000 from bell, my Western Digital My Book external drive is showing in the dashboard as being connected by \\mynetwork is empty. No way to connect to it. Has anybody found out a solution to this? Is there a solution to this or is the WD My book not supported on bells home hub?