WDTV Live 3rd Gen Turns off/on when trying to access a network!

I bought my WDTV 2 weeks ago and it worked fine!, my tv doesnt have hdmi so i had to buy a hdmi to dvi cable and it worked fine…

Today it wouldnt turn on!! (well it turned on, but restarted after a few seconds on the “WD loading…” screen)

So i desconected every cable and used only the component + power

It sent me to the lenguage selection screen… and when i connected the LAN cable, i registered my password and as soon as it joined the network, it reseted itself, and kept doing so until i unpluged the LAN cable…


Other times it said it couldnt get an IP address, those times it didnt reset itself.

So, i said… FINE, ill use WiFi… but the same thing happened… (the video is of me joining the network, the devices reseting a couple of times, and then returning to the language selection screen (no wifi) Heres the video:  http://youtu.be/DUE6CvMFBS4

So… is there a fix??? 

I already tried returning everything to factory settings, reseted using the buton under the unit…  

There may be something else on your network that’s causing the WD to reboot.

Try turning everything else on your network off execpt for the router and try again.

If that works, then you can use process of elimination to see what it is.


got the same problem!

Bought my WDTV yesterday.

Connectet it with the power suply and connected to my Wifi without any problems.

I made the Firmware Upgrade to the newest version and now it is restarting permanently.

I have try to connect it direclt to the internet without a router but it does not work.

I do a reset but it does not help.

I am trying now to set up an old firmware.

Edit: Make a downgrade ;)  http://wdc-de.custhelp.com/app/answers/detail/a_id/8335

now it works for me with an old firmware!

PLEASE post back if a different firmware worked! im going to work now but thats what i was gonna try when i returned!


waiting for a new firmware and if a new one will be released, I will try it again :wink:


Awesome! which one did you use? and also… does it matter that the page is in german? or its the same?

on a side note, i got mine also to work!!! i did… mmm nothing… i disconnected everything last night and today i was gonna start testing different firmwares… but first i said “one more try” and what do you know… it worked :confused:

Folks, I think the timing was coincidence, and this issue is not likely a firmware issue.

There is an ISSUES thread about it, most people are saying that everything is OK now.  

Probably an issue with WD’s servers for a day or two.

I dont think so!!! My WDTV Live isnt working again!!! it worked fine yesterday…

Today, it still resets automatically, but now ADDING to that, when it does turn on correctly, it has a pink hue when im connected through HDMI… (and some times with AV too)

Im now gonna try changing the firmware

I have more or less the same problem.

Sometimes the WD live doesnt turn on but the light on the front is illuminated. It just doesnt give a picture on the TV. Then when I switch the power on and of, only the light goes on and of. But no picture. I have to manualy unplug the power to start up from the beginning. 

I also have the feeling that the WD doenst shut off completely? Is this correct. In other words does the system always, when you press the power button, turn in a state of standby modus?

The search function also does not work. When I try to go to a point in a movie were I ended the day before, the sytem freezes and I have to restart again.

Could it be do to the fact I’m streaming from my NAS?