WDTV live 3rd gen NETFLIX is dead on slingshot in New Zealand

So this problem is current for everyone I know that is running netflix on WDTV live on slingshot in NZ.

Basically Netflix app stopped two weeks ago with some layer 6 SSL issue.

Funnily enough, Netflix still works through the browser on the home network, and via Roku… so its isolated to the WDTV live.

Anyone else had/solved this problem?

We are guessing that there has been some change on the netflix side (which netflix deny …) That has affected the handshake, which is supported by most devices but not WDTV… App need updating maybe?



1 Like

Hi, can you share what firmware version you have? Have you tried to power cycle the WDTV? 

I wasn’t aware that netflix was available in new zealand

if you’re using something like unblock us , you’ll need to check that stuff

next most common reason for netflix failure actually has to do with device time

generally a reboot will solve that

Hi Thanks for the replies…

As mentioned, I also run netflix on other devices and its still running perfectly on Roku… One of our providers “slingshot” runs something called globalmode, which provides access. Bit of a loop hole. But I wouldnt think unblock.us is needed if netflix still runs fine on the network…

Firmware I am using is the latest… **Release 2.01.86 (12/10/2013) **and the device has been rebooted several times, I have used the netflix feature to logout of all devices, thus refreshing the S/N on netflix, and I have also done a factory reset on the WDTV live to no avail.


I have observed the same problem.

When using the diagnostic screen, up,up,down,down,left,right,left,right,up,up,up,up

The error shows up as

 Network /6/SSL handshake failed / http://localcontrol.netflix.com/uiboot

version : 2.01.86/3.1.3-release-907160