WDTV "last content source has been removed."

Just got my WDTV, to make a long story short, i have researched the **bleep** out of this problem.  And, is there no solution? Am i right in guessing that not one human knows the answer?

So, i’ve got my lil WDTV Live hooked up via wire to my router which is hooked up by another wire.  I know its hooked up correctly because i can see the movies i have in my VUZE library. **bleep**, i can even play the first 20 seconds, then i get kicked out and it says “the last content source has been removed.” 

I’m sick of messing with this and searching on the internet and not finding anything…yet knowing i’m not the only one.  Why won’t it work?

can anyone provide simple instructions to make this thing work? 

Things I would do are:

  1. Check to make sure you have proper permissions set up (did the WDTV make you log in when you first connected to the VUZE?)

  2. Are you using static IP addresses. I set every device in my home manually and have no problems now with “the last content source has been removed.”

  3. I do not know VUZE, but I guess you are trying to access it via Network Shares. You can also try media servers option on the WDTV Live if your VUZE has DLNA enabled.

  4. Make sure your cables are at least all cat5e or cat6.

My advice to anyone is always, plug the WDTV Live via usb into your hdd directly, but if you want to use a network setup so that you can share with multiple devices, get a synology NAS (for the movies to be on), a good GigE switch, and cat6 cable. I only have one connection to my internet router (switch port1) and have found that is optimal for me [We have 4 pc’s / Synology NAS / Netgear ReadyNAS (had some problems with this until couple days ago, I do not recommend this brand) / 3 wdtv devices / 2 xbox’s / 3 playstation’s / laptop / ipad / iphones / tv’s / other media players / fridge, all plugged in to my network and I never have any problems like freezing or having to reboot, as I bought good HP switches, and only use cat6 cabling].

I had this problem a lot until I changed my router to use static IPs for everything behind it.  Since then (knock on wood) I have not had it give me this message.  You should at least change the WDTV, your computer, and any other media sources to static.

I fought a similar issue and error message myself.  I found an obscure post that pointed me in the right direction.  I was trying to access Playon running on a media server PC, accessing a D-Link Share Center NAS.  Turns out my media server PC is hard wired to the network, and also setup to do Wifi.  At some point, somehow, it was connected via Wifi and there was confusion with routing when it tried to get back to the WD Live unit.  I simply disabled my Wifi connection on the Media Server PC and used only the hard wired network connection and that fixed it immediately.  Not sure if this applies to you or not.

desmo_lover wrote:

can anyone provide simple instructions to make this thing work? 

Hard to provide assistance when you give so little info.  You mention “VUZE library,” but googling vuze shows that this is some bittorrent client, which is completely irrelevant to the WD TV units.  Why would we care how you are getting your video files?  What we need to know is where the files are stored, how they are being shared/accessed, what format they are in, what your router is, exactly what your complete network configuration is, etc.  Perhaps if you provide more information about relevant aspects of your setup, people might be able to help you figure out how to proceed.