WDTV 3rd Gen Stuck on Boot Screen

Hey guys

I have a WDTV gen 3. Great little thing.

Came home yesterday to find it not booting. This is what happens:

  1. Switch device on by plugging in power
  2. Device powers on, HMDI screen comes on - see the WDTV flash screen
  3. Stays here no flashing lights, but front light on solid. Network lights show some activity (not much) Screen stays, does not progress
  4. Hold down power button on remote… device turns off
  5. Turn device back on using remote.
  6. Hangs at boot screen again. Sits there nothing happening

I thought this might be a firmware issue, so:

  1. Formatted USB key (FAT32)
  2. Downloaded latest official firmware
  3. Copied over files
  4. Edited the version file so it would realise it was a newer firmware
  5. Booted device
  6. Recognised the firmware
  7. Firmware flashed, device rebooted, took out USB key.
  8. Device still sits at boot screen.
  • I have tried this for the last 3 firmwares released from WDTV… still no luck
  • I have also tried the reset button on bottom of device - nothing happens at all - even when held for 30 seconds +
  • I have opened the box and disconnected the power switch to motherboard - still no joy.
  • I have tried connecting to composite only. And still no joy.
  • Does anyone have any suggestions? It seems like a software error not hardware - the device is there it responds to remote control, it flashes the firmware - just nothing after that.
  • I have not tried any unofficial firmwares - and have heard about an emergency flash - but haven’t tried this either.

Thanks for you help and time


 I have opened the box and disconnected the power switch to motherboard - still no joy.

The WDTV Gen3 doesn’t have a power switch.  ???

ah okay well i disconnected the thing that looked like it i saw someone do this with a pervious model.

do you have any ideas on this odd behaviour? 

The only product with a power switch is the WD TV Live HUB – the one with the internal drive (and discussed in another forum.)   Is that what you have?

Nope I have the 3rd Gen WDTV Live Streaming Player

Has Netflix etc… doesn’t have Hard Drive in side.

I am worried the thing is bricked!


Well, depending on what you disconected, it very well may be!  :laughing:

Ha no its reconnected, just a simple plug

I have tried flashing again! No luck

Any ideas?