WDMYCOUD unable to connect refuses connection

I have not found anything on the community or Knowledgebase that addresses my specific problem. Here is the problem. I recently changed from Verizon DSL to Comcast/Xfinity as my internet provider. When I first got the new system I could access the WDMYCLOUD with no problem. Since the second day I have not been able to access the system at all.

Configuration:
I have one user name and password as well as the admin set up.
I have a static IP (which I had before the change in providers) as 192.168.1.xxx This was required since WDMYCOULD kept losing it’s ip when on DHCP. I believe this was caused by Verizon router as I had same problem with other hard wired units and with the wifi.
I have a Netgear GS108E switch between the router and all other units on the network. This was required because the Verizon router could not handle video transfer without losing all configuration. Since Netgear installed no problems. Continues to work fine with switch installed.
I have one Pentium 4 computer with XP and one laptop with Windows 10 also an Epson printer. Printer and Laptop work fine with both hardwired and wifi.


Problem:
I can ping the system so at least to the Network layer everything is ok.
When I access dashboard I get the error Firefox can’t establish a connection to the server at 192.168.1.xxx.
When using Windows explorer (map a drive) I get Windows cannot access
When I try SSH I get connection refused.
When I try FTP I get could not connect to server.

What I have done to date:
I removed the Comcast router from the network - still no connection.
I removed the switch from the network - still no connection
I added NETBIOS over TCP – still no connection
The Comcast router shows the WDMYCLOUD as up and conntected. (Strange because the dlink is shown as down yet connects fine!)

Since I can’t access the dashboard I can’t do a system only reset.
One of the other suggestions was to delete Windows credentials in credential manager. I am reluctant do do this since even the Pentium can’t connect.


Looking for suggestions and help.

Is your router configured to use the same original IP space and have the same DHCP reservations the old router had?

local side as 192.168.1.255 with mask of 255.255.255.0

@Charles_McCubbin
I suggest to 40 second reset the My Cloud and allow it to get a new DHCP IP from your new router/gateway.

That’s a broadcast address. You sure that’s correct?

Yes I know that is the broadcast address. The actual address for the
WDMYCLOUD is 192.168.1.9 with the appropriate mask.

The only problem with the 40 second is that it requires a power down
which I can’t do safely since I can’t access the dashboard - again all
connections are refused.

But it may be the only way to get the system back.

1 Like

Did anyone find a solution to this problem? I have the same, since I installed a new computer (windows10). Can’t acces the dashboard anymore, but I can access the disk itself, and the WDSmartware backup works as well.

My system came back after a hard reset. I was doubtful since I have
lost data in the past with hard resets but it did work. (I sweated the
several minutes it took - felt like an eternity!)

Same problem, with WD EX2 Ultra, disk is connected, blue light light is solid and i can access disk from web browser and from WD Mycloud app, I can normally access data but i cannot access dashboard and also on windows network i cannot connect to it, only work hard 40 sec reset, I did it but after week agian same problem … I cannot do a hard reset every week … any permanent solutions ?