WDMyCloudEX2 Firmware 2.10.310 Breaks Web File Viewer?

Howdy. I just upgraded the Firmware on the WDMyCloudEX2 that I own, and now I find that I am unable to view files on the NAS using the native Web File Viewer app in the same way that it worked before the upgrade.

Whenever I open Web File Viewer, it now shows only the first ten files or folders in a given directory. There is no scroll bar to allow me to view or access the 11th file (and all files following that). It does show in the lower right corner of the screen that I am only seeing “10/39” folders (the directory in question has 39 folders.)

Another quirk… the files I can see are sorted alphabetically. 0-9 then a-z. The first 3 folders begin with “4”, “8”, and “B”, which is as expected. When I created a NEW folder, and I named it “AAA DELETE ME”, the count in the lower right corner incremented from “10/39” to “10/40”, but “AAA DELETE ME” is not shown between “8” and “B”. Tapping the refresh icon refreshes the listing, but the new folder is not displayed. And of course, with no column headers to allow me to sort alphabetically, or by date, there’s no way to gain access to that new folder OR any of the other 29 folders in that directory that aren’t being displayed.

Really disappointed that such a simple feature got annihilated with this firmware update. I’m looking now for a way to roll back to the previous firmware so I can use my NAS.


I’ve performed a reboot (via the MyCloud Dashboard), no change.
I’ve performed a factory reset (holding the reset button on the rear of the NAS for 10+ seconds), no change.

Out of curiosity, try two other web-browsers with your EX2. Just to eliminate the web-browsers from the equation.

Have you tried clearing your browsers cache? This has worked for me in the past with other similar browser issues.