wdmycloud/Twonky assigns wrong IP address to samsung smart tv (2016 model only) and disconnnects after 20-30 minutes


Did anybody have the same issue with the Samsung Smart TV K series (2016)? After 20 - 30 mnutes of streaming a video from MyCloud to my Samsung TV (2016 model) the streaming stops with a ‘disconnected from server’ error message. At the same time, neither the TV nor Mycloud get disconnected from the router/wifi.

I noticed that the IP address set for the TV (XXX.XXX.XX.33) is not the one that MyCloud/Twonky assigns to it (XXX.XXX.XX.34). If I then try to change it in the TV settings and assign a different IP address MyCloud/Twonky still assigns to it one that is different. If I change it in TV settings to the one MyCloud assigned it, then it changes in MyCloud/Twonky by itself to another one immediately. The IP address the router assigns to the TV alternates between these two, i.e. the ‘real’ one and the one Mycloud/Twonky ‘invents’ for the TV, sometimes changing between the two even during streaming.

Rebooting the router and/or MyCloud, disconnecting/reconnecting the TV to the Wifi did not help.

I have another, older Samsung model installed in the same envirtonment and it does not have an issue neither with the ‘fake’ IP (it is consisntet everywhere) nor with disconnecting from the server. (This is why I think the two issues are interrelated.)

Thanks for any help with this, it has been taking my time and driving me crazy.

MyCloud does not assign IP addresses, nor does Twonky; that’s done by the DHCP in your router (unless you set a static IP address at the device).

Twonky only records the IP addresses of devices that connect to it. It’s possible that your TV is using two IP addresses for some reason (e.g. for different functions; there may be one IP address for the TV firmware upgrade/maintenance port, and one IP address for the ‘smart’ function block).

Try resetting the list of media receivers in the Twonky control panel.

If you want to see, or fix, the IP addresses of devices in your network, use the control panel of your router. Does your router show any device assigned the IP address ending .34? Is it the TV, or is it something else?

I suspect you have an IP address conflict somewhere; have you assigned static IP addresses to any devices (at the device end, not the router end)?

1 Like

Thanks for th ereply

“Try resetting the list of media receivers in the Twonky control panel.”

Yes, Ive tried that but it resets to the ‘false’ IP.

“Does your router show any device assigned the IP address ending .34? Is it the TV, or is it something else?”

My router sometimes show .33 and sometimes .34 as the TV in question; never at the same time and alternating randomly, I would say, between the two.

I’m not too sure selecting on the TV menu “enter IP adress manually” and then inputting one that is different from what was there automatically is the same as “assigning static IP address”, but I’ve done that -after the problem was already there. Also after the problem was already there, I changed ‘DHCP’ to ‘Static’ on MyCloud

So I fully don’t understand how the IP adress of the same device can be different in the router and in the MyCloud/Twonky UI… Like I say, the router UI alternates between the one set for the TV in TV settings and another ‘random’ one which is the same displayed in MyCloud Dashboard/Twonky UI. So sometimes you have a situation where the router’s UI and MyCloud Dashboard show different values for the same device…

How does the Samsung TV connect to the router? Via WiFi or by Ethernet wire?

If you haven’t done so already access the router’s administration page and configure/reserve an IP address for the Samsung TV. That should prevent (unless the TV is pulling two IP addresses) the TV from switching back and forth between IP addresses. Or access the TV’s settings and see if you can configure the TV for a static IP. Could be the TV (for what ever reason) is releasing and renewing the IP address if it is set to obtain an IP address automatically.

And as always make sure you update the TV’s firmware (if possible) to the latest version.

1 Like

That’s a good question: if it’s connected by both wired and wifi connections, it will have two IP addresses, and if the WiFi comes and goes, it might be swapping between wired and wifi access, hence the IP address would change.

So, the OP needs to disable one of the connection methods; either turn off WiFi on the TV, or remove the wired connection.

I would recommend leaving all devices to use DHCP to be assigned their IP addresses, and use the router’s UI to then fix the DHCP-allocated addresses for those devices; using some control like ‘always use this address’, ‘infinite lease’, ‘infinite DHCP timeout’, ‘reserve IP address’ etc.

1 Like

As I said in the paragraph after the one you quoted:

The TV is only connected via wifi…

I’ll try that tonight.

The option I have is "Enter IP manually "and then I can specify one I choose. Is it the same as assigning a static IP? Cause that I have done and it didn’t help : Mycloud/Twonky immediately reset (or changed the displayed IP address for the TV on its UI) to a ‘false’ IP.

Yes this is done.

Generally one can EITHER reserve an IP address within the router’s administration section (the DHCP settings) OR one can enter the IP address manually on the TV. You should see your TV’s user manual (or the manufacturer’s website) for more information on how to set a static IP address within the TV settings menu.

Because you are using wireless that may be the cause of the disconnects and the assigning of a different IP address. Generally to avoid this, reserve the IP address within the wireless/wifi router’s administration settings. This way every time the TV connects to the network it should obtain the same IP address each time.

Is there an option to connect it via a wired connection? If so, what happens when you try?

1 Like

So I got around trying the wired connection.

The “encouraging” news is that the moment I changed to wired connection the router assigned it the ‘false’ IP address which MyCloud Dashboard and Twonky also displayed in the wireless connection environment. So it looks like that the mysterious ‘false’ IP is indeed another hidden IP address used by the TV for the wired connection?

The sad news is that once the TV connects to the router through wire then it cannot “see” MyCloud… so I could not test the actual disconnect error (or use MyCloud at all).

So in the end I’m still without a solution, although probably advanced with the diagnosis (?).

My next step personally would be to contact the TV manufacturer and see if there is a way to disable either the wired or wireless connection entirely.

Did you try restarting the router after switching to the wired connection? Also be sure that the TV is disconnected over wireless while connecting with the wired connection.

1 Like

“My next step personally would be to contact the TV manufacturer and see if there is a way to disable either the wired or wireless connection entirely.”
Thanks and you’re pbly right with the advice but we’re talking about a Samsung TV 2016 model i bought 45 days ago :)) The other Samsung TV from 5 years ago works in the same environment no problem and I did not have to call them separately for anything…

“Did you try restarting the router after switching to the wired connection?”
There was no need to - i did not mean it to be a permanent solution, just wanted to see what happens if. And unfortunately I cannot use in this case Mycloud as the TV cannot seem to work both wireless (Mycloud) and wired (router): the TV does not show Mycloud.

“be sure that the TV is disconnected over wireless while connecting with the wired connection”
It is - there is only one internet connection the TV can have any one time.

The reason I asked is because sometimes it takes a restart for the changes to fully take. It’s possible that after a restart in the other configuration it might be able to see the drive.

So I did that, restarting the modem and MyCloud and disconnect/reconnect the TV afterwards.

While in the router the TV is shown with the wireless (correct) IP, it is now displayed with BOTH IP addresses (i.e. with the genuine wireless one I have defined in the TV settings manually and the ‘hidden’ one for wired connection) in both the MyCloud Dashboard and the Twonky UI. Yes, one device with the same MAC displayed twice with two different IPs! Crazy.

As this is a new development I’m now streaming a movie to test… with bated breath for the 30-minute mark…

No. It disconnected.

I’m giving up. Hopefully Samsung will patch this sooner or later.

But it’s clear that the TV can do either wifi or wired, not both…

Things have got quite a lot more complicated in five years… For one thing, Samsung seem to have stopped publishing manuals, apparently preferring ‘online help’.

The TV will connect to the MyCloud via the router, whatever connection the TV is making to the router. The MyCloud doesn’t have wifi, therefore cannot connect directly to your TV.

Resetting the router will force it to update its connection tables, which may resolve IP address resolution issues.

We’re not asking you to do things just for the fun of it…

What is the exact model number of your TV? We might be able to make sense of the instructions.

The model number is UE60KS7000SXXN.

OK I’ll try wired TV/router, then restart router, and see if TV sees mycloud. DO I need to restart also Mycloud?

OK so I have a wired connection now, router restarted.

MyCloud is not shown on TV, TV not shown on MyCloud Dashboard after refreshing the list in Twonky. So I’ll restart MyCloud as well.