WDMy Cloud is missing

#6

Is this a recent purchase?
Have you just put a lot of media on it? If so, it may be busy indexing and thumbnailing the data. It shouldn’t make it disappear, but it can make it very unresponsive. It shouldn’t really, but I’m afraid it does… It may be worth just leaving it to do its thing for a few days (yes, it can take that long…)

When you say you’ve power cycled it, did you shut it down first, or just pull the plug? Pulling the plug on a NAS can cause trouble. And it will restart the indexing, and may need to do a disk scan to check for problems caused by the power removal.

Have you tried either a 4 second or 40 second rest (see the user manual for details)?

Are you sure the cable and router port are okay?

I know it’s frustrating, and we’re only offering ‘have you tried this?’ questions, but it’s quite difficult to diagnose exactly what’s going on.

#7

The 3TB drive has less than 1Tb of data to back up. The dashboard says I have 2.4TB free
When connected I can see activity via the WD simple dashboard.
I have left it for a couple of days and it continues to work away before finally coming up with the message sync complete. Then within a couple of hrs I get the dreaded message WD MYCloud missing.
The 4 sec reset does not do anything to reconnect . The Power cycle seems to reconnect it at least for a short time. Did not know about the 40 sec reset.
I have recently down powered over night and have just re connected the drive. It appears to be indexing as I write this email.
But hey I have been here before.

#8

PS yes this is recent purchase…only 3 weeks ago…have been struggling since I got it.
However it is a rewards point purchase so I can’t return to POS.

#9

I think WD is unable to resolve the current defects. The content database is corrupted easily and the WD Sync product depends on it for it’s functionality. This is the feature that allows them to compete with DropBox, Copy, Drive, QNAP, and the other leaders.

They are being disrupted by the companies like the ones above, but having problems executing on the game plan. I’ve seen inconsistencies in their execution.

The previous post from me when the client says “WDMyCloud is missing” should actually display “Error in DB file location” which means the content database is corrupt.

WD needs to figure out what file type is corrupting the database and live up to the marketing hype. I received a Mirror Gen 2 in lieu of my 4TB mycloud. After a couple of days. It exhibited the same problem. I performed a Quick Restore and copying just my photography related files.

The bigger issue is after a year I still have not created accounts for my family or put up photos, music, or videos for consumption via our connected TVs. When the database gets corrupted the DLNA functionality is gone until the database is rebuilt.

Just my $0.02 and frustrated. @lluna would you be able to consolidate these issues?

Product Page

#10

Appreciate the feedback…as disappointing as it is.
Can I simple re configure and use as a 3TB stand alone hard drive?
If so can you point me to a tutorial or otherwise, as I am frustrated with the WD Cloud efforts.

#11

Me 2… You can use it as a NAS drive, but not as a DAS (direct attached storage). That is how I use it until they resolve.

#12

Bit confused, maybe its the terminology I’m not familiar with.
The drive drops off the network so how can I use it as a NAS with any sort of consistency?

#13

You can use it as a direct attached storage device by connecting the My Cloud Ethernet port direct to the computer’s Ethernet port (making sure to configure both networking ports properly). The USB port on the My Cloud is a host so it cannot be connected direct to a computer to facilitate access.

Otherwise one can void the My Cloud’s warranty and disassemble the device and take out the hard drive and use it like any other bare SATA hard drive.

#14

@Bennor thanks for the knowledge. I knew direct attached via USB was not possible. @John_Camer make sure there is not another device using the same IP address on your network. I’d want to rule that part out first.

#15

Have done that.
Interesting thing is that I can ping the device, when its up, but can’t connect using MyCloud account.

#16

What about the admin (local) account? That is strange.

#17

If by admin account you mean…can I access it via finder on my Mac, then yes I see the Icon in my Shared networks but when I click on it I get the message “cannot connect"

#18

are you using El Capitan? There is a known problem with that OS and Windows 10.

#19

Yes El Capitan…wtf

#20

as I stated in another thread.

#21

Well, to be fair, in this case it appears to be Apple’s software skills that are lacking, as these particular problems only started with the roll-out of El Capitan…

Unless it’s not Apple’s software skills that are lacking, but instead, their marketing people once again insisting that their engineers deliberately break the ability to work with third-party devices…

#22

That I could see with Apple. Now what about the problems with Windows 10? The other issues with the My Cloud line does not help WD make the case “it isn’t us”.

When I did hardware systems integration vendor “A” would call out vendor “B”. The deflection game. I saw that game with RAID arrays, memory, CPUs not bought via the vendor.

#23

For some of us the problems started with the November update to Windows 10. If one does an in internet search they’ll see others, using other NAS boxes, had similar problems starting with the November update. Prior to that update my Win 10 test box had no problems with the My Cloud. Post November the My Cloud no longer shows up under Computer in Windows File Explorer. For me it appears to be some sort of SMB issue in Windows 10 on that one PC where by if I downgrade Windows 10 to SMB1 (via one of the three SMB methods detailed in this thread) it will properly display the My Cloud under Computer.

I do not have these problems with my Windows 7 machines. Including those that were upgraded then rolled back from Win 10.

#24

On the my cloud mirror gen 2 there is an option for Max SMB Protocol under Windows Services.

SMB 1
SMB 2
SMB 3

I’ll try with my atom based netbook. Slow as molasses, but my current test machine before I upgrade next week.

#25

The single drive My Cloud (the subject of this subforum) does not have an option to set the SMB in the Dashboard. One would have to use SSH (or WinSCP or similar software) to edit the smb-global.conf file to change the SMB settings for the My Cloud.