WDMy Cloud is missing

Network loses the device constantly, multiple times daily. Only a power cycle to the device will restore sync, and then only for a couple of hours. Have researched online and have found any many similar experiences amongst users. Have we purchased lemons?

Hi, have you tried to set a static IP on the drive? What version of the firmware do you have on the drive? What is the brand and model of your router?

What are you trying to connect with? PC, Mac, Android?

How are you accessing? via IP address, or device name?

As above, have you set a static IP address, or fixed the router-allocated DHCP IP address (use router’s UI to set infinite DHCP timeout for the MyCloud, or ‘always use this address’, or something similar).

@lluna and @cpt_paranoia, @John_Camer is referring to the problems with the WD Sync where the client responds with WDMyCloud is missing. I too had the same issue and testing my new RMA’d My Cloud Mirror to see if it suffers from the same bug.

The REST API throws a 400 response

Successful MetaDB Info

HTTP/1.1 200 OK
Date: Wed, 18 Nov 2015 07:02:35 GMT
Server: Apache
Vary: Accept-Encoding
X-Orion-Version: 2.7
Content-Length: 248
Content-Type: text/plain; charset=utf-8
Content-Language: en

            "path":"/{userName}/WD Sync",


Failed MetaDB Info Transaction

HTTP/1.1 400 Bad Request
Date: Wed, 18 Nov 2015 13:13:38 GMT
Server: Apache
X-Orion-Version: 2.7
Content-Length: 125
Connection: close
Content-Type: text/plain; charset=utf-8
Content-Language: en

      "error_message":"Error in DB file location"

Have not tried a status IP. Access via dashboard is virtually impossible …keep getting message no device detected. Even though following a power cycle the device begins to sync.
Firmware version is 04.04.01-112.
Router is a netcomm wireless 600.


Is this a recent purchase?
Have you just put a lot of media on it? If so, it may be busy indexing and thumbnailing the data. It shouldn’t make it disappear, but it can make it very unresponsive. It shouldn’t really, but I’m afraid it does… It may be worth just leaving it to do its thing for a few days (yes, it can take that long…)

When you say you’ve power cycled it, did you shut it down first, or just pull the plug? Pulling the plug on a NAS can cause trouble. And it will restart the indexing, and may need to do a disk scan to check for problems caused by the power removal.

Have you tried either a 4 second or 40 second rest (see the user manual for details)?

Are you sure the cable and router port are okay?

I know it’s frustrating, and we’re only offering ‘have you tried this?’ questions, but it’s quite difficult to diagnose exactly what’s going on.

The 3TB drive has less than 1Tb of data to back up. The dashboard says I have 2.4TB free
When connected I can see activity via the WD simple dashboard.
I have left it for a couple of days and it continues to work away before finally coming up with the message sync complete. Then within a couple of hrs I get the dreaded message WD MYCloud missing.
The 4 sec reset does not do anything to reconnect . The Power cycle seems to reconnect it at least for a short time. Did not know about the 40 sec reset.
I have recently down powered over night and have just re connected the drive. It appears to be indexing as I write this email.
But hey I have been here before.

PS yes this is recent purchase…only 3 weeks ago…have been struggling since I got it.
However it is a rewards point purchase so I can’t return to POS.

I think WD is unable to resolve the current defects. The content database is corrupted easily and the WD Sync product depends on it for it’s functionality. This is the feature that allows them to compete with DropBox, Copy, Drive, QNAP, and the other leaders.

They are being disrupted by the companies like the ones above, but having problems executing on the game plan. I’ve seen inconsistencies in their execution.

The previous post from me when the client says “WDMyCloud is missing” should actually display “Error in DB file location” which means the content database is corrupt.

WD needs to figure out what file type is corrupting the database and live up to the marketing hype. I received a Mirror Gen 2 in lieu of my 4TB mycloud. After a couple of days. It exhibited the same problem. I performed a Quick Restore and copying just my photography related files.

The bigger issue is after a year I still have not created accounts for my family or put up photos, music, or videos for consumption via our connected TVs. When the database gets corrupted the DLNA functionality is gone until the database is rebuilt.

Just my $0.02 and frustrated. @lluna would you be able to consolidate these issues?

Product Page

Appreciate the feedback…as disappointing as it is.
Can I simple re configure and use as a 3TB stand alone hard drive?
If so can you point me to a tutorial or otherwise, as I am frustrated with the WD Cloud efforts.

Me 2… You can use it as a NAS drive, but not as a DAS (direct attached storage). That is how I use it until they resolve.

Bit confused, maybe its the terminology I’m not familiar with.
The drive drops off the network so how can I use it as a NAS with any sort of consistency?

You can use it as a direct attached storage device by connecting the My Cloud Ethernet port direct to the computer’s Ethernet port (making sure to configure both networking ports properly). The USB port on the My Cloud is a host so it cannot be connected direct to a computer to facilitate access.

Otherwise one can void the My Cloud’s warranty and disassemble the device and take out the hard drive and use it like any other bare SATA hard drive.

@Bennor thanks for the knowledge. I knew direct attached via USB was not possible. @John_Camer make sure there is not another device using the same IP address on your network. I’d want to rule that part out first.

Have done that.
Interesting thing is that I can ping the device, when its up, but can’t connect using MyCloud account.

What about the admin (local) account? That is strange.

If by admin account you mean…can I access it via finder on my Mac, then yes I see the Icon in my Shared networks but when I click on it I get the message “cannot connect"

are you using El Capitan? There is a known problem with that OS and Windows 10.

Yes El Capitan…wtf

as I stated in another thread.