WDMediaServerPatch.deb produces Error 31101 message invalid firmware package

I just did the upgrade from 021109-053 to 024105-034

when I try to switch from either dlna package using the deb files

I get a 31101 error message saying invalid firmware package

I also tried this

Twonky is missing after upgrading from 021109-053 to 024105-034

http://community.wdc.com/t5/My-Book-Live/Twonky-is-missing-after-upgrading-from-021109-053-to-024105-034/td-p/546090

1 Like

31101 invalid firmware package.jpg

I finally did get a working setup again

I used the downgrade.sh and the rootfs.img from apnc-021109-053-20120413.deb

Then used the update from file method in the wd gui with apnc-023205-046-20120910.deb

Then used the wd update from the web to go to 02.41.05 – 034

which did have a working twonky installed

I then was able to install WDMediaServerPatch.deb

and then back to Twonky5MediaServerPatch.deb

My best guess is maybe it has something to do with the prior state of 021109-053

and going directly to 024105-034 that there might be an issue

as I tried that combo a few times, without luck

but going from 021109-053 to 023205-046 and then to 024105-034 worked as it should have