Wdidle3 not working on new BLUE drives ;-( Any help?

WD’s reply for my drives is: “Unfortunately, Intellipark feature or idle time settings for the hard drive cannot be changed, this feature is used to safely park the mount head when there is no read/write operation to secure data stored on platters from damage.” But no mention on what the life of the drive on this parameter is.

Since I haven’t read this forum a long time, I’m not sure if somebody is being interested, but here are the info I have:

  1. If you have just regular drive in you system (let say disk F:)- you can create .bat file:

    :start
    echo . > f:\file.dat
    timeout 6
    goto start

Then start this task in windows scheduler, it will not show console window, so it will just work
This is simplest method
2. Also, as I found out, when you started extended smart test on you drive it wont park its heads for whole time of the test which is around 10 hours (as I recall). Al we need to do the same approach as at I said at first case, but .bat file will be as follows:

:start
D:\Sys\smartmontools\bin\smartctl.exe -X /dev/hdc 
D:\Sys\smartmontools\bin\smartctl.exe -t offline /dev/hdc
timeout 36000
goto start

A few notes: this is the WINDOWS version of tool, but it needs Linux-style of your device drive identifier.

Although I’m “IT guy” I’m not really aware of HDD internals, this is very specific area. All I found out - just two methods to tackle the problem. As I tested - both methods work and they don’t make any noticable performance impact of the drive. If I could return my blue drive I would do it instead of digging forums and making such pathetic crutches :slight_smile:

As of today - the drive still works without any problems or errors, so - you decide. Please see attached screen shot of hddscan . Also you can start extended smart test by the hddscan (http://hddscan.com) tool and check load/unload count after then.

Thank you for sharing.
I made a preventLCC.sh script that I use on a Ubuntu machine.

#!/bin/bash
FILE=/data/preventLCC.tmp
USER=rimidalv

while true
do
        /bin/echo "Temp file to prevent LCC. This file is overwritten every 4 seconds" > $FILE
        /usr/sbin/smartctl -a /dev/sda | grep Load_Cycle_Count >> $FILE
        /bin/chown $USER:$USER $FILE
        /bin/bash -c '/bin/dd if=/dev/sda of=/dev/null count=1 skip=${RANDOM}' >/dev/null 2>&1
        /bin/bash -c '/bin/echo ${RANDOM}' >> $FILE
        /bin/sleep 4
done

You call it in a root crontab like this.

sudo su
crontab -e

Add

@reboot /data/preventLCC.sh

Does it work? As I recall, it may need to create/delete the file.
I highly suspect if we just read SMART info - drive wont park its heads. I tried this by clicking the “Smart” button on HDDScan tool - it shows regular SMART registers, but seems reset parking rimeout at the same time.

Well > $FILE overwrites the file which is the same as deleting it and creating it again. While >> $FILE appends to the end of the file.

Before i stumbled upon this thread I left watch 'smartctl -a /devsda | grep Load_Cycle_Count' open in a terminal window, which runs the command every two seconds. I left it working for about two weeks and saw no increase in LCC. I then rebooted the PC and forgot to run the command again and it racked up LCC to 10 000.
The dd command reads a random sector and does nothing with it, bit paranoid i know:) . So far i havent seen any increase in LCC.

Its a shame that WD wont let us disable aggressive parking. My PC is always on and I do not need any power saving features. Had I known this was the issue i wouldn’t have bought this drive.

This is a OK solution, but it does not solve a lot of scenarios. For instance if a computer freezes and its left untenanted, LCC will rack up in no time.

If the PC frozen it wont make LCC increase, I think, because LCC is growing while we access the drive after 8 seconds idle timeout, then wait then access again and so on. Also, I agree with you that it can’t solve many other scenarios.

This is ridiculous and unacceptable, I’ve had many WD Green drives and now Blue drives where I changed the aggressive parking with wdile3 easily and without complications that was one of BIG reasons for me to choose Western Digital and never had any problems from even HDDs running now for 8-7 years and now that I recently bought a new WD Blue HDD and I decided to change it, I can’t because WD decided to block it for no “apparent reason”

Is very obvious that is a shameless move to force people to stick with the aggressive intellipark of 8 secs so our drives wear down faster and we have to replace them, REMOVING the options for the consumers is not cool and it’s in fact disgusting, they already did something like this a few years ago for the WD Reds when they decided to block the tool to disable the TLER but I never expected that they will go so far to block wdile3 too.

the Load Cycle Count has always been a big issue with WD Greens and now Blue drives but at least we had the tool but now we’re screwed.

My WD Blue drive has been running for around 4 months and it already has a Load/Unload Cycle Count of 42000

FIX THIS IMMEDIATELY WD or you will lose our trust, we’re not DUMB.

For anyone using a Synology NAS or Linux I’ve written a bash script based on @Rimidalv’s post.

Paste it into Notepad++, set Edit > EOL Conversion > UNIX (LF) and save as preventLCC.sh
The script has the ability to log temperatures and LCC if you so desire.

#!/bin/bash
myname="${0##*/}"
myver="ver0.1"
myyear="2018"
myauthor="sB-x"
myref="Reference: community.wd.com/u/rimidalv"

definterval=4

writetolog () {
case "$arg_log" in "")
    echo "not_logging: $1"
;;*)
    echo "logging: $1"
    echo `date "+%Y-%m-%d %H:%M:%S"`, "$arg_device: $1" >>$arg_log 2>&1 || error_exit "error_log"
;;esac;
}

logsmartctl () {
    smartctl_out=$(smartctl -d sat -a $arg_device | egrep "Temperature_Celsius|Load_Cycle_Count")
    
    if [[ $arg_lcc ]];
    then
        smartctl_log="lcc/$(echo -e "$(echo -e $smartctl_out | cut -d"-" -f 2 | cut -d" " -f 2)" | tr -d '[:space:]')"
    fi

    if [[ $arg_temp ]];
    then
        if [[ ! $smartctl_log = "" ]];
        then
            smartctl_log=$smartctl_log", "
        fi
        smartctl_log=$smartctl_log"temp/$(echo -e "$(echo -e $smartctl_out | cut -d"-" -f 3 | cut -d" " -f 2)" | tr -d '[:space:]')"
    fi

    if [[ ! $smartctl_log = "" ]];
    then
        writetolog "$smartctl_log"
    fi
}

error_exit () {
    echo "not_logging: $1"
}

positional=()
while [[ $# -gt 0 ]];
do key="$1"
case $key in -h)
    arg_help=true
    shift
    ;;-i)
    arg_interval="$2"
    shift
    shift
    ;;-t)
    arg_temp=true
    shift
    ;;-c)
    arg_lcc=true
    shift
    ;;-r)
    arg_test=true
    shift
    ;;-l)
    arg_log="$2"
    shift
    shift
    ;;*)
    positional+=("$1")
    shift
    ;;esac;
done

set -- "${positional[@]}"
arg_device=$1

if [[ $arg_help || $# -eq 0 ]];
then
    echo $myname $myver
    echo "Copyright (C) $myyear, $myauthor. $myref"
    echo
    echo Usage: $myname [options] device
    echo
    echo "  "-l log_path
    echo "      "Log file path
    echo "  "-i interval
    echo "      "Interval in seconds
    echo "      "Default: $definterval
    echo "  "-c
    echo "      "Log load cycle count
    echo "  "-t
    echo "      "Log temperature
    echo "  "-r
    echo "      "Test run
    echo "  "-h
    echo "      "This help
    echo
    exit 1
fi

case "$arg_interval" in "")
    arg_interval=$definterval
;;''|*[!0-9]*)
    writetolog "error_interval"
    exit 1
;;esac;

if [[ ! -b $arg_device ]]; then
    writetolog "error_device"
    exit 1
fi

while true;
do
    logsmartctl

    if [[ $arg_test ]];
    then
        exit 1
    fi

    sleep $arg_interval
done

exit 1

Synology NAS users can add a scheduled task to run as root on boot-up with the script:

bash <path_to_preventLCC.sh> <your_device>

Use fdisk -l to find the correct device.

It’s advised that you SSH in and copy the script to a location that’s not shared eg. /volume1/myscripts/ to eliminate any risk of modification.

Use this install script if needed:

#!/bin/bash
loc_source=<source_path>
loc_dest=<destination_parent_path>

rm -I -r "$loc_dest/$(basename "$loc_source")"
mkdir -p "$loc_dest/$(basename "$loc_source")"
cp -a "$loc_source" "$loc_dest"
chown -hR root:root "$loc_dest/$(basename "$loc_source")"

I had no trouble doing this using Ultimate Boot CD. I put the ISO on a thumbdrive, made sure only the WD Blue was connected, changing the controller in the BIOS from ACHII to IDE and booted from the thumbdrive. Once I changed to 300 seconds I switched the PC off, later booted to verify if changes were permanent.

WD Blue 6TB (nov 2017)
Firmware: 80.00A80

Image screenshot

2 Likes

I was able to disable head parking today on a brand new WD Red 6TB. I use the Ultimate Boot CD the poster above me linked to.

WD RED 6TB (WD60EFRX)
Build Date : July 2018
Firmware : 82.00A82

You need to do a cold power down after changing this setting for it to take effect.

I also have a 6TB WD Green which has been running with head parking disabled for 3 years, and shows only 970 load/unload cycles.

But last year I tried to disable parking on some new WD Red 8TB and it did not work. So for WD Red drives, it seems 6TB is the max size allowed. Green drives are gone, but I’m not sure what the story is with Blue and Purple drives.

2 Likes

bought new wd60ezrz and in 1 days use i have already 160 LCC count on one and 95 on another

same issue that plagued green drives long time ago… and guess what i disabled in the green drives using wdidle3 in 2010 and that drive still works today without any issues 9 years latter ( backup drive most of the time )

the HDDs will last because wd puts quality over quantity but this is stupid move :slight_smile:

you can only use wdidle3 if you are conected on a sata port… if the druive is in usb3.0 enclosure will not be detected…

could disable all my wd60ezrz with the ultimate boot cd and WDidle tool like in the past

thanks

1 Like

I . bought a WD Blue WD40EZRZ 2 years ago and another one recently. both no problem to use wdidle3 copied on a FreeDOS USB and change the Intellipark settings.

I dont have your issues.

Although WD Firmware update software does not detect the disks. not sure why.
I have firmware 80