WDGeneralNetworkError error 500 when viewing photos/videos in ios app

I bought WD My Cloud recently and updated to the latest firmware " WDMyCloud v04.01.02-417 : Core F/W". In general the device works OK. There is some issues with creating safepoint but that is not daily usage anyway.

But the issue of viewing photos/videos on ios does not work as expected. When I click “Photos” or “Videos” on the bottom, the “WDGeneralNetworkError error 500” would appear. And this happens with every ios device (iphone/ipad).

A few days ago I called the WD support. As instructed, I restarted the router and My Cloud and tried to disable the firewall on router and then it worked. So we thought that might be the problem of firewall. But later I enabled the firewall on router and it still works. But when I moved files around and reboot the device, it does not work anymore. So I think the root cause is not firewall. It might be some crazy combination of operations I tried that fixed the issue temporarily by chance (I tried reboot, rebuild media database, disable/enable media service and cloud access, disable/enable the wdmcserverd through ssh, remove some files that wdmcsever failed to process, etc.).

The capacity on dashboard is not available now but it is available when the ios works normally.

I found a post about similar but different problem and it mentioned about the location of apache2 error log at “/var/log/apache2/error.log”. Wheneven “WDGeneralNetworkError erro 500” appears on ios device, there is the following in the error.log:

[Sat Jan 10 05:20:45.990048 2015] [:error] [pid 21145] [client] streamFileOutput|array (\n 0 => ‘HY000’,\n 1 => 1,\n 2 => ‘no such table: Files’,\n)
[Sat Jan 10 05:20:45.990159 2015] [:error] [pid 21145] [client] streamFileOutput|SELECT fileTable.isDeleted, path, size, category, lastModifiedDate, name , dateTime FROM Files fileTable , ImageMetadata catTable WHERE fileTable.Id = catTable.sourceId AND path LIKE “/photos/%” ESCAPE “\” AND isHidden = 0 AND fileTable.isDeleted = 0 ORDER BY lastModifiedDate DESC limit 500
[Sat Jan 10 05:20:45.990313 2015] [:error] [pid 21145] [client] PHP Fatal error: Call to a member function execute() on a non-object in /var/www/rest-api/api/Metadata/includes/db_info.inc on line 182

So it was trying to find information from table “Files” and the db querry operation is failed.

Does anyone see similar things, or can WD provide a method to fix that?

I tried to rebuild the database for a few times and even restore the system to factory, but none of them worked.


Hi there and welcome to the WD community.

Since you are running the firewall on your router and if you disable the firewall and are able to access the unit with  no problems, id there a possibility that you can create exceptions n that firewall? You can try this to see if it can fix your issue.

Hi ArMak,

Like I mentioned in the original post, when I was calling the WD support I disabled firewall and it worked. So at that time I and the WD technician thought the firewall be the root cause.

However, afterwards I just enabled the firewall again and it was also working normally for a few days until I move files around and reboot. Then it does not work and I struggled for a few days now.

Surprisingly, it is working now! I am thinking hard about what did I do?

Anyway, I am glad that it is finaly working. It seems the system is kind of fragile and hopefully the log I attached could mean something to WD engineers.



There was a power outage and the my cloud is not working anymore after reboot.

I will contact WD later to figure out what should do.


Did you get any formal answer from WD about this ?

Thanks for feedback !

What happens when you choose Pictures/photos and click on ALL?

Posted by,
cat0w (USA)

It happens exactly what this post is about … WDGeneralNetworkError error 500. And if you click on ALL, you’re getting back to the list of folders.

OK, I know I am on an Android phone, but how about under Photo, View All Photos? See image below. If I click on View by Date or View by Album I get nothing. What do you see if you click/tap on the three dots next to Photos on your phone?

Posted by,
cat0w (USA)

It does just what i said before :slight_smile:

The iOS view is different. When you access the ‘Images’ folder (I’m using French version of the app), you are immediately on the ‘ALL’ images and you get the error. If I click on the ‘Photos’ icon just next to ‘All’, i also get an error, but a different one (‘Operation not valid. It already exist a file at this location …’).