WDFME.exe Process Keeps Running


#1

I have Passport SE Essential and Vista Business OS.  Often, the WDFME.exe process keeps running and takes over my machine.  The only way to stop it is to reboot.  Can’t even safely eject it because of error.  I have to reboot nearly daily.  How do I stop this process from taking over my machine?  Any help would be appreciated.


#2

I’m having the exact same proble with “My Book Essential” back up drive.

The WDFME.exe is eating up between 70-95% of my CPU - pushing all other progams to back.

This can’t be right.  No point in having a “backup” if I can’t generate any “new” work to be backed up.

Ideas?


#3

I’ve settled with just killing the process when it runs when I don’t want it to.  I use the Windows backup to do backups now.  This process is just too taxing.  Hopefully, this will get fixed with software updates.


#4

Do you have Smartware installed? It can be a real resource hog. I did one backup and uninstalled it.

Joe


#5

As I wrote in a similar post:  http://community.wdc.com/t5/My-Book-for-PC/Disabling-WD-File-Management-Engine-WDFME-EXE/m-p/108858/highlight/false#M3972:

Hmm… I just found I have this issue as well. I don’t use any of the features of this software, so have opted for a complete uninstall. 

I do use the encrypted drive / password functionality, but what I’ve done is just created a shortcut from my quicklaunch bar to the W:\unlock.exe program (where W:\ is the drive letter assigned to virtual CD drive that comes with this external drive. 

That way I plug it in, click on that shortcut, and unlock my drive, without needing all the other software ■■■■.


#6

Ihave the same problem!

Any solutions?!


#7

There are three solutions… one is to refrain using Smartware. This is possible if you’re not planning to use Smartware as your sole backup solution. Smartware do not offer drivers. Windows native drivers do the job.

Second is to uninstall Smartware and use VCD to unlock your drive using unlock.exe located on the VCD (virtual drive), if you still prefer to use password drive lock feature.

Third option is to uninstall older version of Smartware and install latest version of Smartware. This version claims to be free from subjected problem but I doubt that. (BTW I am not using Smartware anymore)


#8

Hi,

This drive has locked up my computer repeatedly. It doesn’t respond to a control-alt-delete so I can’t even identify which process is causing all the problems. I have to power off the entire computer because it won’t even close down properly sometimes.

Even worst it now takes over 20 minutes boot. They system simply seems to stop in the middle of a boot and then wait (no hard drive activity). This is without the drive attached.

How do you go about uninstalling this lousy program? Or updating it to something that doesn’t crash?

I can’t find wdfme.exe in my process list at the moment.

I can’t find Smartware in my list of installed programs. What name does it hide under?

I did update the firmware on the dirve to the latest version… but the system still locks up even when the drive is not inserted… so that’s not to helpful.

Any help much appreciated.

:slight_smile:


#9

I updated.  No change.


#10

Amigo1

You may have some other issue. This my not be directly related to Smartware. Try disconnecting all external drives and reboot. This could well be malfunctioning drive symptom. Check on task manager for higher CPU allocated applications if you still see the problem after disconnecting drives.


#11

I thought it might be a failing drive so I’ve just finished checking the drive… but Seagate utilities shows up nothing wrong on the drive.

Tried turning USB legacy on/off with no change.

The system was working properly immediately before plugging in the WD drive… and ever since has been playing up.

The boot problem occurs even when the drive is not connected. The machine only locks up when the drive is connected… and usually after copying some files… not straight away.

It sounds a bit like the problems in this thread… but not exactly the same. Should I start a new thread?

When it plays up you can’t check to see which process is creating the problem as no new processes can be launched and you can’t shut down anything either (mouse is still moving so not a total lock-up).

After booting it runs fine… so other than the long wait to boot there’s nothing else wrong with it.

The  machine is an AMD x6 Phenom with 4GB memory. 32 Bit Win7, 1TB boot drive (Seagate), 1.5TB WD drive (for storage). Asrock motherboard with SATA3, USB3, onboard graphics and DDR3 memory. Everything is pretty new and the whole thing runs off a UPS to protect it from power fluctuations.

Anyone got some ideas?

:slight_smile:


#12

My problem was solved by removing email from the list of backup items.

Microsoft Outlook email files (*.pst and *.ost) are very large and constantly changing.  The continuous changes cause the backup operation to perpetually process this file for backup.  Being a very large file (over 2GB in my case) the disk never stopped spinning and trying to back up the file.  It simply can’t keep up.

When I unmarked email from the backup process, smartware calmed down.  It works great now.  Exactly as i would have hoped.

I have to manually back up my outlook.ost and (archive).pst files, but it’s a small price to pay.  Also, my corporate email is backed up online anyway, so I’m not at risk of losing email even if there’s a crash.  Many companies offer the same online backup of email, so it’s possible that this will work for you, too.


#13

Lock up and 20 minute delay appear to be unrelated.

The delay went away as soon as I switched SATA cables on my storage drive!!!

Problem was that I appear to have 2 SATA cables that have been playing up… so switching cables didn’t help.

These are cheap and nasty SATA cables so I’m not surprised.

I finally diagnosed the problem when my boot drive also started to play up after I started using one of the other SATA ports… and thus one of the other cables.

What a pain!!!

Unfortunately you don’t seem to be able to buy a quality SATA cable anywhere!

I trouble shot the whole thing by cloning the entire boot drive to a second disk. That way I could safely experiment with the copy safe in the knowledge that I could go back to the original if something went wrong.

At least my new boot drive is faster than my old one (SATA3 v’s SATA2). Cut about 10 seconds (maybe more) off my boot time.

:slight_smile:


#14

I am having exactly the same problem.  I just got my WD HD yesterday.  It’s currently unplugged and I have rebooted since, but WDFME is taking 50% of my CPU and the laptop is roasting!

I am going to kill the software and uninstall, don’t really need it.

For everyone who is looking for good free backup software, I highly recommend Cobian Backup.

Cobian allows Full and Differential backups to multiple locations, and you can define multiple backups (Music, Photos etc), which I find handy for backing up my laptop over a wireless network, with my WD HD’s attached to a desktop.


#15

Having the identical issue, except this machine is still on WinXP 32-bit.  WDFME taking up over 50% of CPU, and the backup drive isn’t even plugged in.  What gives??


#16

Same problem here under WinXP Pro with SP3 and I have even installed that latest 1.4.5.2 update of SmartWare that’s dated 22nd March 2011 so no joy with updates, guys.

WDFME.EXE shows in Task Manager as the culprit.

This is terrible because my comp is very old. It’s only meant to be temporary until I can get around to researching and buying an up-to-date one. My primary internal hard drive is thrashing, which is bad because it is 6 years old and I bought the WD My Passport Essential to back up from there. There is a major delay even in opening the start menu and Notepad. This is completely unacceptable.

I have no option but to uninstall SmartWare. I bought the WD drive solely on the basis of it having an easy backup facility!!!

So WD is like HP - good hardware but bad, bad software.


#17

The only comfort in reading all of your reply’s is that I am not the only one.  It did not take me long to uninstall Smartware (aka Run-on-ware).  What surprised me is that WD hasn’t leaped into the fray and fixed this.  Word of mouth at the point of sales places is running them into the ground just like HP. 


#18

I have the same problem and am using Windows XP.  WDFME.exe continues to use 75% of my CPU, and I turned WD backup off.  I uninstalled and re-installed the latest version.   No change.  Still 75%.

I decided to uninstall the WD Smartware.  Only then did it stop using my CPU.


#19

Here is a fun additional one.  As you know , I have uninstalled of the Smartware (now there is an Oxymoron) and this morning there was WDFME running its little heart out.  I used taskmanager to kill the proc.  More news to follow.

Grandpa Coffee


#20

Same problem. Killing the WDFME.exe process solves the CPU usage problem, and the WD Smartware seems to continue functioning just fine. Am I mistaken? It would appear that this component is unnecessary for the backup operation. Is there an option somewhere to simply disable the software that needs the WDFME.exe executable?