WDC750 Black - not recognized by ICH9 on Asus MB - HighPoint Controller works fine


#1

Hello!

First I must say that I didn’t know WDC had a support forum, and if I’d known this earlier it would probably have saved me quite a lot of trial and error over the past years. Oh well, better late than never :slight_smile:

Alright, here’s the deal:

My 750gb Blacks (got 3 in total) have been running for a little more than a year now on my HighPoint RocketRAID 2320 controller. But recently I’ve been updating my server, and the 750gb’s had to get demoted down to the onboard ICH controller on the Asus P5B Deluxe motherboard. This however, caused a few problems. One of the drives didn’t get recognized by my BIOS (updated version BTW).

Inside the BIOS itself it detected that something was connected to the desired SATA-port, but it could tell what. It only said “Hard Disk 0gb” or something similar. Inside Windows 7 x64 nothing appeared under diskmgmt.

So I thought I’d try the drive in my other computer, which also happens to be running with an Asus motherboard, Maximus Formula in this case, with a ICH9 SATA-controller. However, this gave me the exact same results as the first computer.

So then I figured I’d try out the Lifeguard Diagnostics tool from WDC, and I booted up into it, only to receive an error about a file not being in the right place. When I double-checked the DVD which I’d burned the .iso to, to check that the files were installed properly, everything looked alright.

Then I decided to try the Windows installation version of Lifeguard, and that one didn’t pick up the disk either.

So, then I reconnected the drive to my HighPoint RocketRAID 2320-controller, and once again, the drive popper up, and everything looked fine. CHKDSK gave me 0 bad sectors as well as HDTune. I also tried the disk on my HighPoint RocketRAID 1740-controller, only to receive the same result I got from the 2320-version. Now the Lifeguard utility did pick up the drive, but I got an error when running the test, though, I received the same error when I tried to run the test on any drive that wasn’t connected to the onboard-controller. It said something about “no sectors to read”.

To sum it all up:

  • The drive does NOT work when plugged into any of my Asus MB’s
  • The drive DOES work when plugged into ANY of my HighPoint RocketRAID-controllers
  • BIOS on both computers + RAID-controllers (onboard and external) is up2date
  • WDC Lifeguard was not able to pick up any information about the drive when connected to any MB

NOTE: My two other IDENTICAL drives (even from the same batch) are working PERFECTLY fine on ALL controllers, including both of my MB’s. Also, all 3 drives have previously worked together with the onboard-controllers.

Thanks in advance, I’ve sent an RMA request back to my store, and it did get approved, however, I wouldn’t mind finding a solution for this.

//hab


#2

I have experienced lots of the same issues for the past 2 years or so.

I also spoke with an RMA rep from Cybertron PC and he said he noticed ALOT of RMA’d drives from users with Intel Matrix problems, specifically with WD drives. He said they retest them and put them back into inventory almost every time.

Every time the following conditions are true:

  • Western digital SATA hard drive works initially

  • After some point, it doesnt work in an Asus Motherboard

  • Often times will freeze the bootup while it’s trying to detect a drive on whatever particular port it’s plugged into

  • All asus motherboards tested had Intel Matrix capable controllers

  • Using the HDD in another motherboard without the matrix capable controller results in a working hard drive

  • Using just about any cheapo PCI-e SATAII controller will see the drive

I have determined that the best course of action, of course until we figure out what is wrong, is to simply buy inexpensive SATA/RAID controllers.

Other important fact to consider: I almost always buy asus motherboards. I feel that it’s an intel matrix problem.


#3

I am glad to see that this is in fact a known issue.

However, I find is shocking that intel hasn’t fixed this problem, because I’m pretty I’ve had this with all my Asus boards over the years, but normally it fixed itself by changing the SATA-port on the board.

And yes, I’m also getting the freezes at bootup etc. Sounds like we’ve experienced the same problem here.

Maybe I should forward this thread to Intel somehow.


#4

Alright, just was in contact with Intel, and they had no clue what was going on.

Guess I’ll try Asus then.