WDBlackSN750 500gb GPT - MBR Cloned

I cloned my MBR initialized SATA SSD to my new M2 NVME SSD, now I preserved the GPT format in the new drive utilizing aomei backupper professional software to clone it. Now I reset, disconnect old SATA SSD enter bios, new SSD appears like a bootable drive, change to UEFI boot mode, restart again, but then it crashes and blue screen appear, it says there’s a problem and needs to restart, then it seems rebooting but nothing appears on the screen and stuck like this. Now, is the GPT format really better in my case? Because cloning it and applying MBR worked just fine. If GPT format is really the best option please help me!
This is how my drives looked when i tried to boot from NVME M.2 SSD initialized as GPT:

You can’t clone a MBR partitioned SSD to a GPT partitioned SSD directley because the cloned drive can’t boot.

Procedure:

  1. If the new SSD is already GPT partitioned, and you want to clone the MBR drive to the GPT drive, you must convert the new GPT partitioned SSD to MBR first.

  2. Clone the old MBR SSD to the a new MBR SSd.

  3. Convert the new MBR SSD to GPT.

Thanks for the help.
Do you know a reliable software that can convert from MBR to GPT without erasing any data on the new SSD?

I’ve had the same problem and solved it with EaseUS Partition Master, Professional Edition … works fine to me.

It’s not a free edition, but maybe the free one also works.
https://www.easeus.com/partition-manager-software/free-convert-mbr-to-gpt-without-data-loss.html

Thanks for the help, i should check your answer as a solution once i get everything done right?