WDBFJK0080HBK always have ot change USB port

My Setup:

  • Asrock H97m Pro4
  • Windows 7 Ultimate 64 Bit (Servicepack 1)
  • (Updated all drivers including the WDs firmware to rule that possibility out)

After one month suddenly a problem arises with my 8TB external WD MY BOOK drive. After I remove the power suply for some time and then put it back on while my computer is running to access my files on the external drive it won’t recognize the drive. Putting the usb connector out and back in won’t help. There are only 2 options to get access.

  1. restart windows
  2. put the usb connector in a different usb port. The next time it happens I have to change to an other USB port again.

Both options are very inconvenient and I hope someone can help me to find a satisfying solution before I have to send the dirve back and try an other brand. I don’t want to use any additional software either just to work around that problem.

Hi, are you using the ports from the motherboard or from a USB hub? Are your ports USB 3.0?

Well, I tried the USB ports 3.0 from my motherboard and the 3.0 ports from my PCI-E extension card. Both giving the same result.