Quick note - I see similar topics, but not quite a full answer or explanation…
I have two older 4TB drives, My Book, and both power supplies seem to have failed after I moved from the east coast. I’m a bit frantic to get the data off at least one of them. (One was working drive, and the other my time machine backup).

When connected to power, the light on the front just flashes when wiggled. I tried swapping power cords, and no dice. I tried using a different power cord, same issue. Led to believe it’s the female end soldered to the board on both giving the issue.

I removed from the enclosure, and removed controller, and they are unreadable.

My thoughts are two below:
1 - Can I order a drive that has same model and just use the controller from that to access the data? No passwords were set-up on either drive. I found an NESN drive ( WDBFJK0040HBK-04 model vs. WDBFJK0040HBK-NESN) - do these interchange?

2 - I have another similar model drive WDBAAF0010HBK-00 1009C
Would the controller from that work?

3 - the third option would be the linux data recovery option I saw on another thread here. I’d like to avoid this, as i can predict some data loss or messing this up. lol

Thanks in advance!


as long as the drives are WD. You can remove the drive from the old bridgeboard and connect to a new WD bridgeboard to access your old drive. I believe you can even connect the drive to the computer using the SATA port.

I know that pulling the drive and simply putting into a SATA enclosure will not work.
That control board has something to do with accessing the data. It shows as empty when dropped into a SATA enclosure.

Hoping that by using a control board from the same model, I can access my data.

The problem, in both of these drives, is that the female port (soldered to control board) is not functioning properly. Both of them, after unpacking from a move, will not power on. They flash as you wiggle the power cords. I’ve tried different power cords to no avail.

If I put into a SATA enclosure minus the board (required) - it shows as unreadable, but the discs immediately spin up.

WD support has totally side-stepped my question on this, and referred me to data recovery services.

IF that’s all I will get from them, these are the last two WD drives I will ever own.

So that mean the power port on the board is loose. If you can solder try it out. There should be 5 pins connect to the board, 4 pins are ground and 1 pin for power. Back then I was able to swap board to drive and drive to board. But it like WD program its firmware to only work with certain model of WD hard drive. Good luck.

okay, so I figured I would share this since it worked like a champ.

I found another drive on ebay iwth the same part number.
Cracked open the case, borrowed the control board, plugged it in - and BAM - worked like a champ.
All of my data is there.

Why WD wouldn’t just let us know this, I have no idea.
Rather than help us use their product, even like this as a last resort, they only pointed me to drive recovery companies. I just asked the same as I asked here. “Would this theoretically work?” - no response.

I’ve got these working now, and need to go buy a couple of replacement drives today to move data.
Any guesses as to what I’m buying? (hint: not WD. Never again).

Hope this helps someone else out.