WDBFJK0020HBK not seen by Windows10


#1

Hi. I recently purchased a HP Pavilion laptop. My WDBFJK0020HBK drive worked fine on my windows7 laptop (still does). When I attach it to my new windows10 laptop it does not appear. (Not in Device Manager or File Explorer). The Blue light on the drive comes on and it vibrates. I tried removing power and restarting but nothing appears.

HELP!


#2

Hi kendaggtbs,

You can follow the steps provided in below article in this concern:


#3

I followed the instructions for Direct Attached Storage (DAS) on Windows.

When no drive appeared in Explorer I downloaded and installed WD Discovery.

I repeated the power down and restarted following the instructions. The MyBook did not appear in either Explorer of WD Discovery.

The blue light appeared on the MyBook both times.

The MyBook still mounts under Windows 7.

Help???


#4

Hi kendaggtbs,

It seems that it’s a system specific issue as My Book mounts on Windows 7 but not on Windows 10. You should check the status and health of My Book in Windows Disk Management. Please refer below article to check My Book in Disk Management and for more details:


#5

Hi again,

I tried what you suggested on the Win10 machine. In Device Manager the drive did not appear in Disk Drives or Other Devices. It did not appear in Disk Management either.

I tried what you suggested on the Win7 machine. In Device Manager the drive appears under Disk Drives. It also appears in Quick View which indicates that the drive is good and NOT locked.

What can I try next?


#6

Have you loaded all the latest drivers and firmware for your new laptop?


#7

As far as I know. It’s a brand new laptop and I’ve asked for all the latest downloads. Where do I find the latest for WD?


#8

In a six month period I went through 4 New Gaming Laptops, 3 of which had hardware problems and all 4 laptops did NOT have the latest firmware or drivers. Your problem seems to be with your new Laptop, think of it being shipped with the 1.0 version of all the drivers and firmware. On the 4 new laptops I worked with, they were usually one or two subversion behind on the firmware and many of the drivers were updated too.