WDBACY5000ABK-01

I have an old backup drive (WDBACY5000ABK-01) that I’m trying to use with my MacBook Air laptop. The OS is macOS Sonoma 14.1.1.

I’m getting the following error: DriveUnlock needs to be updated. Please advise.

Hi @DivisionOne
Have you opened a Support Case? If not opened, for more information, please contact the WD Technical Support team for the best assistance and troubleshooting: