WDBABV0010BBK - USB device not recognised


#1

Hi,

Recently, I bought  1TB elements disk (P/N: WDBABV0010BBK). For a week this disk worked fine. I managed to transfer all my personal videos and photos of last 12 years on this disk from another WD 250 GB hard disk. It was also working fine after transferring and I was able to access them as well. 

But after a week this disk stopped working. I mean, when I connect it to my laptop (where it worked earlier) I get a message “USB device not recognised…”. LED is also not coming on when it is connected. There is simply no activity that happens when it is connected to Laptop.

This problem started after I connected this disk to my SONY TV. The other disk (WD 250 GB) is working fine when connected to TV.

I thought it was a cable problem and hence replaced cable. But no luck there.

I can get it replaced as it is in warrantly period (i guess) but that won’t work as WD doesn’t recover the data. And I need all my personal data as I don’t have another copy :frowning: I know, it was a huge mistake to have relied on HDD alone but it was a lesson learnt a hard way.

Can anyone help me to get this drive working or suggest how to recover data without losing the seal so that I can request for replacement? Pleaseeee… 


#2

You probably want to post that question in the right forum:

http://community.wdc.com/t5/Other-Externals/bd-p/BoardExample3


#3

Thanks TonyPh12345.

BTW, just an update. Yesterday, I tried with another micro USB cable that I got along with San Francisco. And it worked temporarily. It looks like there is a bad connection at the drive end. If I move the cable and put it in right position (Trial and error), it gets detected. not sure whether the connection lead got burnt as I had connected it with the Sony LCD tv.

I copied all my data. I can peacefully request for a replacement now.

Thanks.



#4

I think that your problem is the same of mine. The problem is in the drive USB connector, it get loose with time. I would like to see this hypothesis discussed in this forum.