WD7500BPKT and Acer 5750G

I recently bought a WD7500BPKT hard drive to upgrade my Acer Aspire 5750G (750 GB, 7200 RPM). Not a huge upgrade from the 500 GB 5400 RPM but something I wanted nonetheless. Any way, here is the issue.

I was planning on cloning my old drive to the new one using the WD Acronis tool which I was able to do successfully with the new drive in an external enclosure. However, the new hard drive is not recognized by BIOS when put it in as the primary drive. When it is hooked up using an external enclosure, it is recognized immediately and works fine. I have to believe the connection is good in the laptop as the old drive still works without a hitch (currently writing this on the laptop with the old drive). I have tried updating and downgrading the BIOS just to see if anything is wrong there with no luck. The drive has no jumper installed which I believe to be right (not that it came with a jumper anyway). BIOS settings appear correct (not that many to choose from in the first place so it would be hard to screw up).

 I am at a loss. Any help would be appreciated.  Thanks!

Acer 5750G
Intel i7-2670QM
8GB Ram

Windows 7 Home Premium 64 bit

Did you get this fixed?  Also, did you make the drive bootable when you cloned it. I would check in Acronis to make sure that isn’t an added step.

Nope.  Never became bootable or recognized by BIOS.  Followed all the steps to a tee and nada.  Tried numerous different ways to get it at least recognized by BIOS to no avail.  Decided to try RMAing it to see if it was just some weird defect.  I will update when the new drive arrives (assuming they honor the RMA). 

Hopefully that solves the problem because it is driving me crazy that something that is normally so simple is giving me such a hard time and headache. Seeing as though you are the first response I have received in quite a while from multiple communities, this is obviously a very unusual problem.  Thanks for at least responding.  

Sorry I couldn’t do more.