WD7500AARS visibility problem in a enclosure

Hi! I recently bought a hard disk WD7500AARS with a enclosure Gembird EE3-USATA-1, put it in the enclosure, set it how it says in instruction and connected to my computer through USB, but it doesn’t seen the hard disk. When I bought it, I asked the seller for some jumpers, cause there was no one, but he tells me that for SATA disk it’s not need any jumpers, that computer will automatically find new hardware. So, that’s my question, is it need a jumper for hard disk WD7500AARS to use it in a enclosure? If not, please, help me to handle this problem with visibility. I have some experience with such device, I have another enclosure, but with an IDE hard disk and I haven’t any problems with its visibility. For information, my system is Windows XP, when I have bought it, I don’t expect any problem like this.

Hey there, some enclosures require Jumpers on the drive to make it  compatible, I found the Jumper settings for the drives on WD web site on the link below, however, I would recommend you to get in contact with the enclosure manufacturer and verify if there is any particular settings or compatibility issues just to confirm the drive is supported by the enclosure.


The problem solved out by connect the enclosure to another USB port, it become visible, I think the cause is that first time I connected it to a slowly concentrator, but there is another problem , it can’t be formatted, I tried to format it by the system program and it gives me an error, then I tried PartitionMagic, but it also gives me an error, I think it has a serial spoilage, defect, cause I get this error on 94% when it was formatting, and that is on its first use. You think I must bring it back there where I bought it to change?