wd75000bpkt, lenovo t420, Device\Ide\iaStor0, did not respond within the timeout period

Hello Guru’s,

After some advice, just bought a new wd75000bpkt drive to use for backup of my laptop data. this was to replace the wd blue 320 i had.

I’m getting the following errors when trying to write data to the device (it’s connected via the sata interface and an external sata 2.5" enclosure). the errors are;

An error was detected on device \Device\Harddisk1\DR6 during a paging operation.

The device, \Device\Ide\iaStor0, did not respond within the timeout period.

the net result is that the copy start off about 80 MBps then suddenly drops and eventually crawls where i then give up. the red light is also permanently illuminated on the external enclosure rather than the green one (startech.com external enclosure).

any help would be appreciated, as dont want to just assume the drive is faulty to RMA it if it is a software issue.

many thanks in advance.

regards, adrian

It could be a compatibility problem with the external enclosure. If possible try connecting the hard drive directly to a computer motherboard and verify if the problem continues, you may also run a test using DLG. Click on the following link for more information. 


Many thanks for responding, i’ve also tried the drive on my hp microserver that has an external sata connection as well, the same problem is seen. if the drive is connected in another box just using usb, it works, but isnt a great transfer speed. I’ve tested the external sata box with a samsung 160GB sata drive I have, and dont see any problems. The drive has passed both the diagnostics and the zeroing all the blocks, going to raise the issue with startech as well, but got a feeling there is something wrong with the cache memory on the drive.

thanks adrian

The problem might be related with the hard drive not receiving enough energy to work correctly, have you tried connecting the wd75000bpkt internally on the Lenovo laptop?

many thanks for the suggestion, i have also tried it on the external sata connection on my hp microserver running ubuntu and the same thing happens (where it just slows down to a crawl).

not sure if there is any verbose diagnostic out there to help diagnose what is going wrong?

thanks in advance.

regards, adrian

When the read/writes slow to a crawl, it’s usually an indication that the drive wasn’t formatted correctly if it’s an Advanced Format drive.  That drive is an Advanced Format drive.  How did you partition and format it - what operating system?