WD5000LPCX MAC Internal HD cannot run any Apps

Early 2011 MacBook Pro 13" with WD5000LPCX internal 500GB HD (replacement for original Toshiba 750GB HD) that was not shutting down. Searching Options, cursors passed over and accidently activeated FORCE QUIT… Laptop shut down.
Next use of laptop No APPS worked. Started up (good Chimes) ok… Could see all files on desktop, documents and other folders. Double clicking on any photo, screenshot or App just brought up a dialogue box "There is no application set to open document “xxdocumentname.wtf” or “You can’t open the application “Calendar.app” (or whatever other APP you chose) because it may be damaged or incomplete.”. Most APP icons turned into “?” (question mark).
Could NOT do back RECOVERY with back-up Time Machine as it requires an APP to operate. Could NOT use original CDs to erase/install the original operating system as CD reader buzzed intermittently several times and ejected the disc (assuming it needed an APP to read CD?). swapped out WD drive for old Toshiba (good chimes but OS never started up, laptop shut off). CDs never worked either. Switched back to WD drive.
Is there basic software/firmware built in other than the operating system?
If so, how can it be replaced? (no APPs working)
Is my (easy/only) option: find an old working MAC, install the WD HD and use Time Machine to do a RESTORE?

Hi @Jaunty,

Please refer to the article for WD Products: Download Software, Firmware, Drivers: WD Products: Download Software, Firmware, Drivers

Please contact the WD Technical Support team for best assistance and troubleshooting:https://support-en.wd.com/app/ask