WD5000avvs won't work in my PC


#1

I have a 500 G SATA hard drive from Western Digital (WD5000AVVS) which was pulled out of a working DVR. I installed it in a PC but the drive is not detected. I have other SATA drives which run fine and I run Windows 7 off an 80G IDE hard drive.

In BIOS: It gives a third master drive error Press F1 to resume. On F1 the boot screen hangs up for a long time. Attempt at entering BIOS with the hard drive hooked up results in a freeze up. My other SATA drives are detected just fine and cause no freezes by themselves (I suppose BIOS driver issue ruled out)

In Windows: Win 7 disk management, no sign of the hard drive.

In Linux: Hard drive detected and I am able to use the partition editor  to manipulate the drive, like formatting and partitioning. (So hard drive defect ruled out)

In WD diagnostic tools (DOS based): The drive is detected and no errors found. (So the hard drive is good).

Tried all the possible jumper settings without success.

Now the kicker: When I try to boot up in Windows after manipulating using the Linux, no problems for the first boot. Windows and BIOS will detect it just fine and Disk management can partition/format and even store files etc. When I reboot, the Drive creates problems again – not detected at boot up or in Windows.

So what is going on?? Hard drive diagnostics check out ok, works fine on Linux but no joy on Windows. On top of that, it will work fine on the first boot after Linux play but fails again on subsequent boot up.

Is there issue with it because it is pulled off a DVR and it is advertised to be dedicated for DVR or media players?? Can it be redeemed??

System setup: ASUS mobo (A8N VM CSM) updated to the latest BIOS (1007)

OS: Windows 7 64-bit running off 80G IDE hard drive (on Cable select )


#2
  • First of all, our AV drives are not designed for fast random read / writes, like you’ll find on our desktop drives.  So, performance will not be that good. 
  • Moreover, on some DVR boxes we write firmware that’s specific to that vendor, and if that’s the case, then it may not be readable - except maybe on a linux system (because the drive’s are partitioned in linux).
  • Aside from those two exceptions, a WD AV drive should be visible and useable in a desktop environment.  You might try to somehow write zero’s to the drive, and see if that causes it to be seen.

#3

Thanks for that response. Seems to answer some of the questions. 

I can see how a specific hardware related firmware could make the drive unreadable on Windows but readable on Linux. Is there a firmware upgrade to circumvent this issue?

Also, after deleting partitions and / or formatting in Linux, I am able to see the drive in Windows (and BIOS) at first boot. It is lost again in subsequent boots. Can this be due to the firmware rewriting/destroying the partitions?

I tried writing zeroes to the drive (the abbreviated version) without any joy. Do you suppose I should use the WD diag tool to write zeroes all across the drive (very time consuming)?

Another question, can I use third party partition manager (Acronis Disk Director) to make it work??


#4

Maybe the drive is configured to Power Up In Standby (PUIS), in which Linux may know how to wake it up, but BIOS and Windows may not. After Linux has woken it up, then BIOS and Windows will see it.

See http://en.wikipedia.org/wiki/Power-up_in_standby

"Power-up in standby (PUIS) or power management 2 mode (PM2)(Western Digital specific) is a SATA or Parallel ATA (aka PATA) hard disk configuration which prevents the drive from automatic spinup when power is applied. The spinup occurs later by an ATA command, only when the disk is needed, to conserve electric power.

PUIS requires corresponding BIOS support. If PM2 is enabled on the drive but not supported by the BIOS, the drive will not be detected by the system or detected as zero in size. PM2 can usually be enabled by a jumper shunt on the drive but can be configured by other means (configuration sector) using manufacturer specific tools."

WD SATA and EIDE Hard Drives Jumper Settings:
http://www.wdc.com/en/library/eide/2579-001037.pdf