wd5000avds firmware

I bought a wd5000avds hard drive but cannot initialize in order to format, etc.

Before returning it in for replacement, I read that it may be helpful to get the firmware in the drive even though it is supposed to be in there already and working.  Anyway, I’m willing to give it a try, but I cannot find the firmware anywhere in the site… could anyone help?

Many thanks

Hi, most internal hard drives don’t have firmware updates available. Follow the link below to review the steps to initialize the HDD, if it doesn’t work you need to replace it.



many thanks for your reply.

I know the process of initializing the drive, has not worked.  A friend of mine had the same problem with a Seagate drive he bought, he contacted the company, they emailed him the initial firmware (not an update)  and the drive worked perfectly.  Actually after a discussion with him, he advised me to contact the company - i.e. the company of the hard drive… but no reply yet, so I thought I may be able to find the solution through the forum.

So, there is no way to find the original-initial firware of the drive anywhere?


No one has somewhere to point me, as to where a firmware can be found (even the original/initial one)?

WD still to reply…

Hi ok if you did get firmware and flash it there goes your warranty. Next maybe it is my problem but I can not see buying anything new not have it work and play with it to get it to work void your warranty and have it stop working in a month. Replacing the drive should be your only choice.