WD5000AAKX Firmware 18 Bug shows no Temperature


I’ve several Versions of the WD5000AAKX

I startet whit Firmware Version 15 and there were no Poblems up to FW17.

Now all of the HDDs buyable have Firmware 18 and this Firmware does not show any Temperature.

I’ve used Smartmontools, different Version, Linux WinXP. I also tried it with HD-Tune 2.55.

Does any one have a clue how to solve this issue?

WD isn’t known for supporting newer Firmwares.

( I also tried a FW15 board on an FW18 HDD but there are to many changes and it’s malfunction already in BIOS. :wink:

A straight board swap won’t work with modern drives. Each PCB stores unique, drive specific “adaptive” data in flash memory on the PCB. Moreover, the majority of the firmware is stored in a hidden System Area on the platters, not on the PCB.

SMART data normally include at least one of two temperature attributes, either Temperature (attribute 194) or Airflow Temperature (attribute 190), or both. The latter is sometimes referred to as Temperature Difference from 100.

See http://en.wikipedia.org/wiki/S.M.A.R.T.

Smartctl (smartmontools) has an “scttemp” option which displays a temperature history for your drive, include the current, maximum, and minimum temperatures for the current power cycle.


that are the technical details i’ve missed to write.

Smartmontools just show nothing between 193(Cycle Count) and 196(Realocated Event Count) 

FW is 18.01H18 (~April.2012)

But my intension is to get the HDD working to determ if the firmware is buggy and the Temperature sensor is functional or if it’s by design without an sensor and all hope lost.

It isn’t very funny to retest all different SW Version regarding if there is an error report:

  • for Smartmoontools in Linux,Windows in all different used Versions

  • the different versions of the Windows application using the sensor

And then decide if the HDD can be used or just send them back, hoping they haven`t bought 1000er lots and just use another type with hopefully no new bugs  :wink:

You should still be able to determine the drive’s temperature from attribute 190. In fact the drive really only has one temperature sensor, and attributes 190 and 194 both use this same sensor.

Smartmoontools allows you to add “quirky” HDDs to its database, after which smartctl would be able to correctly interpret their SMART attributes. I would ask at the smartmoontools forum to see if this has already been done.

Alternatively, I believe that the following smartctl command line option should correctly display your drive’s temperature:

-v 190,tempminmax,Temperature_Celsius