WD5000AADS Green Froze and Preventing Boot


#1

Hello,

On Saturday I ordered a new clickfree backup system. Tonight my hard drive crashed (Tuesday). What the heck!?!

The WD Caviar  is my data/game drive. I have an SSD as system drive.

I was playing World of Goo to relax and the game froze. So, I killed the process and tried to restart. Steam gave an error that the memory wasn’t properly dumped and wouldn’t restart. So, I rebooted the computer. In windows, I tried to restart Steam, but it wasn’t found. Sure enough, windows isn’t showing my Caviar.

I restarted again and my Bios won’t pick up any of my drives with the Caviar plugged. If I unplug, BIOS sees the drives. I don’t hear a loud click of death, but there is a slight “kick” several times about 5-10 seconds into spin-up. 

Please help!


#2

When I switch from IDE to ACHI mode, the disc is found as “hard disc”. In device manager it shows up as ATA device. All recovery tools see it as having 0 sectors and 0KB in size. 

Is this a candidate for replacing the control panel?


#3

Run the Data LifeGuard tools.  If these also state problem, then it will qualify for RMA