WD5000AACS - slow read but write ok


#1

model: WD5000AACS  aka Green 500GB 16MB cache (made: April 2009)

summary: i need a solution to copy my 1GB movies out fast !!!

======

anyone got this problem of slow read but write ok?

i am using this drive as a network storage (dlink nas dns-323) … formatted with ext2.   it was ok for the last few months until this week… the read speed drops to few kb/s… but still the write speed is **STILL** ok - few Mb/s. it is only 1/3 full around 100GB full.

i had no problem with another WD Green 1TB in the network storage… so it is definity not a problem with my NAS.

  1. i tried copy between drive within my network storage… it is very slow…

  2. i tried to insert into my main computer and run linux live cd to copy to another drive and the transfer rate is so slow that the action was terminated by the live cd.

for small files, say few kb big… it is within acceptable speed.

is there any solution in OS level or software level to copy out the files?


#2

I can’t imagine what is causing the problem, but it  might be useful to run the WD Data Lifeguard Diagnostics on the drive. You need to connect it directly to the box I believe. I realise its formatted as ext2 but I would hope that the DLG works at a lower level than that.


#3

I have exactly the same problem (with a 2TB Green), except that I have windows XP on that machine and I’ve formated in NTFS with Acronis. 

The transfer rate is about… 500k/sec between 2 disks (not partitions, disks). I’ll try to put in into another machine, maybe reformat with Windows 7, but I really don’t know what is the problem.

I ran WD Lifegard, both Quick test and Extend Test and there’s no errors…

If somebody know why… tell me!


#4

There are some basic things you can try…

  • replace the cable
  • try another port
  • are they getting enough power? is the system overloaded with peripherals?
  • definitely try it in another pc to see if it works better
  • update you mb and bios drivers

#5

I’ve had this same problem with several 1TB Blacks and several 1TB Blues.  I believe it to be a design flaw in the drives themselves.  Some are fine, but MANY are defective to where the drive read speed is unusable.  Video editing is certainly out of the question with drives that experience this problem.  As for a solution, there is no cure other than replacing the drive, and hoping you get one that doesn’t have the same problem.  Good luck!  There are a ton of those defective drives still being shipped by WD.