WD4000 Harddrive is only 1.63TB instead of 4TB (3.8TB)

Hi, I bought a new internal hard drive (4TB). When I want to format it so it becomes only 1.63TB in windows7. With Mac OS it is 1.81TB. I have tried to solve it through DiskManager i Mac OS so with no success. What do i do wrong.

(Tried to partition the disk with one block - same result).


It needs to be GPT, not MBR.

It sounds like you reformatted it MBR.

I did according to this with no success. I used the interface method but i could now se it as an 1.81 TB in a PC enviroment.


Is it possible that something has created a HPA?

How many LBAs do HD Sentinel or CrystalDiskInfo report?

To remove the HPA, if it exists, you could try any of the following tools:


I am experiencing the same issue.

  1. The disk is new and was initialized as GPT, but even so shows up as 1678GB

  2. I set up an identical drive 2 weeks ago at 4TB

  3. The only difference is the system they were initialized on. The drive that was set up 2 weeks ago was on Win 8 in an external USB bay. The new drive was initialized on server 2012 on SATA.

More oddness:

A) Even inside the DISKPART utility, and after moving the new drive to the external USB bay on the WIn 8 system, it shows up at 1678GB. I also did a CLEAN on it and no change.

B) The drive that was successfully formatted to 4TB shows up at 1.64TB in the disk manager on Server 2012, even though it contains a 3.64TB partition.

If a disc utility such as HD Sentinel or CrystalDiskInfo is reporting a capacity of 4TB, then the problem could be a 32-bit LBA limitation in your SATA driver.

I experienced this too, and when I used the WD diagnostic tool it reported bad blocks which it couldn’t repair so I RMAd it straight away.  The other 4TB black I got at the same timeseems to be operating fine. Perhaps it is a hardware/firmware issue?