WD40 EFRX (WD Red) successful install from scratch

Only for information I managed to install a fresh DX4000 Sentinel starting from 4.0Tb WD40EFRX red drives. As usual the whitelist file had to modified both on the memory sticks (recreate and recovery) as well as on the virtual DVD. The only minor drawback: I did not manage to recreate the RAID from 4 drives directly, the DX4000 got stuck somewhere. With two drives the RAID create did work. Of course expanding to 4 drives in this way will need extratime for the migration after the W2008 installation will be completed. Next step maybe will be to see whether a 6 Tb red drive fresh install will work even if I have some doubt due to the very old Intel Raid version on board this NAS.

I remin the WD RED drives not only are still available, as far as I know, but they have much better thermal management and they are significantly cooler with respect to the original enterprise drives the DX4000 was shipped with.

As added information after some attempts I also managed to re-create the RAID using 4 WD40EFRX WD red drives. The re-create function (via USB key) was somewhat unpredictable but it worked after having diskpart cleaned the 4 disks (on another machine). Then I created the USB boot from a 1.7.6.21 virtual DVD (with amended whitelist.xml) and I simply amended the two WHITELIST*.XML files on the USB stick replacing one of the 4 Tb entries with the WD RED model number. In some other attempts with almost identical configurations I obtained either BAD CONFIG errors or other strange errors. It is really difficult to understand what I did wrong. In another test I did it looks like the 6 Tb HD was recognized as such, but I need to make a dedicated install to be sure a 24 Tb RAID 5 NAS (18Tb of data) can be used on the DX4000.

I would like to see the actual edits you make to the xml files, As I think the format is hard to figure out. How do you determine what to put in there?

This is how I modified the WHITELIST files on the “re-create USB”, same modifications were done on the recover USB as well as in the virtual DVD folder. Just replaced the model number of one of the 4 Tb WD approved hd with WD40EFRX-68N32N0. That’s it

Please note I had to modify the xml files into a txt file as otherwise the upload would not have worked

whitelist.txt (2.5 KB)

Please try to forget my ignorance. I did not understand the “virtual DVD” part. The mounting of the recovery/recreate image world be done on my desktop right?

On win 7 and above you dbl click the iso and it mounts as a virtual DVD.

Thank you Gramps, thank you.
I have successfully installed two 4 TB Red NAS and two 4TB WD Blue drives.
The trick as you stated, do RE-CREAT to create the raid and then do the recovery.
Cheersssssss

out of interest did you have any luck with the 6TB drive?
:grinning:

it was in my todo list for the spare time but did not have the chance to try… I will let you know in case I will find time especially for the editing of the Whtelist files with the correct information of the WD 6 Tb red drives

:+1:much appreciated

I made a first try (raid recreate) without success. As not even the logfile was initialized (so no possibility to investigate issues) either the drives are not even recognized from the very start or maybe I did something wrong. I will have to retry with a USB key created from a clean 1.7.6.21 virtual DVD to see what happens and if I can get at least e logfile.

sounds like it did not like or boot from the thumb drive

good point, next try will have to be with another thumb drive. Indeed the DX4000 was showing “initializing recovery…” but got stuck there without any error

It worked with 2 WD RED hard drives 6 Tb, just tested with a simple RAID0 install with 2 drives but no doubt it will work with 4 drives with RAID5 configuration. It shows 5,5 Tb free. The first try did not work probably because of an incompatibility with the thumb drive as it was correctly suggested by Gramps.

In the “virtual DVD” I used to create the thumb drives (recreate and recovery) I introduced this line for the 6Tb WD RED in the WhielistK and WhitelistS files:

WDC WD60EFRX-68L0BN1

Great work
Thanks
I am sure you meant to say RAID 1
Latest iso is what 1.7.6.21?

Again, thanks for keeping us in the loop.

Of course it was Raid 1, not Raid 0 (i.e. full mirror) - I copied 1.7.6.21 to a hard disk foder and patched there the WHITLIST* files, then created the thumb drives and proceeded as usual.

Useful to know and could benefit those who do a rebuild. Regarding the whitelist how did you complete the full drive specification. Did you just edit an existing entry by changing drive name?

Below you will find the entries for the whitelistk and whitelists files in order to add both the 4Tb and 6Tb WD RED drive.

In one case I modified an existing entry (WD RED 6Tb in the example below), for the 4Tb instead I added a new entry.

This was done on the directory (WDRECOVERY) where I copied the DVD image (files are originally read only, so I changed them to R/W and then back R only). By creating the thumb drives from this patched DVD image you already have updated hard disk lists. But you can also modify the files directly on the thumb drives (re-create and recovery) created from the original 1.7.6.21 DVD image.

One thing I noted is that after you re-create the storage it is advisable/mandatory to install the WD patch. I was going to expand the 2x6Tb DX4000 -> 4x6Tb but the two HDs added after the install were not recognized till I used the patch (most likely there is yet another whitelist file in the WD W2008 install).

Model description=“Enterprise Storage 6 TB” size=“5723167” etype=“constant”>WDC WD60EFRX-68L0BN1

Model description=“Enterprise Storage 4 TB” size=“3815448” etype=“constant”>WDC WD4000FYYZ-01UL1B0

Thanks for this detail it makes it much clearer.
much appreciated :+1:

only for information I failed to migrate from 2x6Tb (which installed flawalessly) to WD RED to 4x6Tb, the migration started but got stuck around 5%. Then I made an attempt starting directly from 4x6Tb: re-create was OK, recovery was OK, but at the restart following the completion of the recovery process the DX4000 got stuch with the standard “… OS initializing…” message. I will have to make some further investigations but so far I can only confirm it worked the 2x6Tb RAID1 config.