WD3200MEY - My PC does not identify WD external hard drive


#1

I bought my Western Digital 320GB USB powered drive back in 2008 and it worked fine almost an year and started having problems. Sometimes it shows the files on the drive some other times it does not. And it works when I connect one of my laptops but not on others.

One of my friends suggested to run CHKDSK utility on this drive when I connect to my Windows XP PC. I startted CHKDSK, it ran more than 12 hours and never completed. I had force shutdown my laptop to stop it. 

After this episode, when I connect my hard drive,

(1) The light on the hard drive comes on but I hear no noise of any sort from the disk

(2) In My Computer, it does not appear as a drive

(3) In Device Manager, it appears in “Other Devices” --> USB Device but shows no properties for this device. It displays the following for the "Device status " in USB Device properties windows when I click on properties

===

The drivers for this device are not installed. (Code 28)

To reinstall the drivers for this device, click Reinstall Driver.

===

(4) I tried connecting to other laptops but it does not appear in my other laptop as well. 

Can someone please advise if there are other options that I can try before resorting to data recovery services? Things that I can try myself to see if I can recover the data. This drive not under warranty anymore and I have some important data that I want to recover.

I highly appreciate your help!

Satheesh


#2

when you have a response please let me know [deleted for privacy].


#3

Must be a “time” problem…hahaha.  I’ve had the same problem today.  My Desktop which still runs on Windows XP can read the WD external hard drive and so did my new laptop running Windows 2007…that is until this morning!  Now the WD external hard drive is “hidden” on the laptop but still “visible” on the desktop.  I called WD Support and they are closed for the weekend.  We’ll check on Mon, unless we can fix it this weekend.


#4

Thanks to thanarath I was able to fix the problem (see below).  May work for you too.

thanarath

Regular Advisor

thanarath

Posts: 222

Registered: 02-03-2010

2

Re: My Passport Essential SE–Cant recognise by Vista

Options

02-19-2010 02:32 PM

It sounds like you have turned the security when you were using it from winXP computer.

If only you are using it and do not need to enter password.

I would suggest you remove the password.

Here is how to do it:

From the WD Smartware menu click on Settings

Click on Drive Settings

Click on Security

Under the Password enter your old password

Make sure that Remove Security is selected

Then Click on the Update Security Settings

That would remove the password.

Unplug the WD external drive and plug it back in for the new change to take effect.

Click the Kudos star to say thank you for helpful posts. And be sure to come back to click the ‘Accept as Solution’ button for the post that solved your issue. This may help someone else.