WD3200js only starts in standby

I’m trying to recycle a WD3200JS I pulled out of a DVR (legally; I hate throwing things away so I wanna reuse it).

I cannot get it to spin up and be recognized by any operating system. If I stick it back in the almost dead DVR, it will take a bit , but spins up and works. If, while still in there, I pull the data cable and attach a USB/Serial dongle, and then put it in my laptop, it is recognized. I’ve then erased using various tools, reformatted in varioius ways in Linux, Mac OS and Windows, but as soon as it powers down it won’t start up again until back home in the DVR.

I tried use hdparm and setting the start in standby parameter to 0, and spin down to 0, but I get errors and it doesn’t appear this get written to the drive.

I suspect there’s either some sort of firmware lock, or something about the cabling in the DVR that’s different. No jumpers are attached to the drive.

Ideas? I’m stumped. And before I drill holes in it and chuck it I’d like to try everything.


If even when connected to the DVR it takes a while to start, it would seem that the HDD is faulty, so not a lot you can do here.

No, the drive isn’t faulty.

Drives often have setting (PUIS, PM2) that start them in standby to await an instruction to spin up.

I finally managed to get SMART data, and it seems fine. The trick is now to change the standby, power management settings.

What I need is a tool that I can use to change the PUIS/PM2 setting. I

Some of WD’s earlier models had a PUIS firmware bug. AIUI, WD never bothered to fix it, but here is a solution:

I found that; thanks. The problem is that all that old technology ( Floppy what?) presents it’s own challenges. Since I can only access the drive via USB, not having any computer with internal sata cables I can get to (fracking iMacs!!) some of the solutions don’t work…I’m trying with some virtual Linux and DOS machines. It has become quite the adventure.

Turns out, for those searching, that it’s extremely difficult or not possible to remedy this situation (the WD PUIS bug) without a PC with SATA internal drives. I tried to run a PUIS script that would reset the power up in standby parameters, but couldn’t get it to work via USB. Usually the drivers weren’t on the DOS disks I used, or for one reason or other it couldn’t write to it, yada yada. WD is no help; they just RMA’d the drives and these are long out of warranty.

And in any case, I wouldn’t trust these drives at this point. A bug in firmware isn’t a good recommendation. So I destroyed them.

Didn’t really convince me I should ever buy a WD drive…glad I at least learned that lesson. But I didn’t lose data, so I can’t complain too much.

USB mass storage devices use a SCSI-like command set whereas WD’s Vendor Specific Commands are tunneled through to the drive via ATA SMART Read/Write Log commands. In any case the MHDD script in that other thread requires that a drive appear as a PATA HDD.

BTW, you could run MHDD from a bootable USB flash drive.

Tried that; MHDD couldn’t find it when booted via two different USB enclosures. And I also booted via USB sticks.  Even when already up and spinning.  When I did connect them via PATA the computer wouldn’t boot; per other instructions you need to somehow connect them via something besides USB, and yet get the computer to boot, and yet keep them spun up, so that you can run a custom PUIS script in MHDD. Beyond what I had available. Search on PUIS.zip in dealdatabase forum if you want to go down this road. I gave up.

I did learn to be more careful about drive purchases. Some are easier to fix than others, although all of the major brands leave something to be desired IMHO. But at least with prices going down it’s maybe not that big an issue; nobody seems to be making anything that a consumer can fix. Or even install a battery replacement. Sheesh.