WD3200BEVT drive - device not ready

Hi Guys,

Ok i got a doozy here for you.

I have a WD3200BEVT drive which was in a Dell Studio PC. My wife was using it and then the PC locked up and she needed to reboot. Upon reboot, it said “No boot device”.  Sometimes BIOS sees the drive, sometimes it doesnt. I took the drive out and tried to slave it to another PC. I ran the BartPE CD and when you try to access the drive, it says “Device not ready”. She has alot of pictures on here that she wants. I have also tried to do a F8 and tried to boot up in safe mode (Windows Vista) but it doesnt boot.  When i look at it from a Linux Boot CD, it sees multiple NTFS partitions, but no drive letter. Active Boot Disk, sees the partition but says sector 0 has a error.  Also from the Linux Boot CD, it says it found 8,452 cluster mismatches and to run chkdsk. I cant do that because the drive doesnt come up and get device not ready error. Is there anyway I can get this data off or fix it?



This software, Partition Table Doctor, might help you to fix the error in the sector 0.