WD3200AVJS not recognized as a valid drive

I have a WD3200AVJS and a WD5000AVVS that were in  DVRs used for recording TV shows.  I want to reformat them to use in a desktop computer.  Neither one will come up as a recognized drive in the bios list or in Data Lifeguard tools or in Acronis, WD edition. Is it possible to reset these drives and if so, how do I do it??

Do the drives spin up? If not, then it may be that they have been configured to Power Up In Standby (PUIS). Has a PM2 jumper been installed?

Jumper Settings for WD SATA and EIDE Hard Drives:

Alternatively, if PUIS has been enabled in firmware, then you could disable it using HDAT2:

You will need to launch HDAT2 with the /w switch to wake up the drives.


check out my post on HDDGuru forums.

At around the end of page two of


You need to use MHDD to reset the PUIS…

My post is copied below…


this post gives some clearer instructions on how to do this using the script files provided by Guru in the following discussion
in puis.zip (also attached here for simplicity - thanks guru).
Please note, guru says
“As the weather is nice and I am in a good mood
Use the script and .bin file with MHDD.
I cannot support this and will not accept PM’s :O)
This is a hack but it does work ( I have tested it)”

I used this successfully to reset drives that had been PUIS’d by my RocketRaid RAID controller.
My drives were WD10EACS 1TB WD Green drives but the original post worked on 500GB drives.
So, I am assuming it will work on most WD drives.

The problem I had was trying to run the script as a BATCH file, which is the impression the thread gives…
The main trick is to put the files from Guru in to the script sub-directory and then run using .puis.
Nobody seems to say that to run a script you should use type .scriptname once you have selected the device.
(So, I will say how to run a MHDD script here so that this post comes up in searches)

 You will need to use version 4.5 of MHDD to run the script.
 A Mint Linux (or others may work) boot CD will help - to get the drive to spin up initially.
 A floppy disk drive or vfd ( http://sourceforge.net/projects/vfd/) and Nero (or similar) to make a boot CD.

Please check that you don’t have the PUIS/PM2 jumper set on your HD!  This will overide the software settings…

 Insert a floppy in to your drive or make a virtual floppy using vfd.
 Make a bootable floppy of MHDD - using the bootable floppy version of the MHDD download
 Extract the two files from the puis.zip file in to the script directory of the MHDD.zip file on the floppy
 If you are using a real floppy you can reboot to the floppy, otherwise you need to make a boot CD from the virtual floppy using Nero.

As the drives show up as blank in BIOS (if not spun up) then it is hard to identify the right drive for fixing.  So, I recommend shutting down, attaching the problem drive and uplugging the sata cables from other drives for extra safety.  Then boot up to your Linux Mint CD and Mint will detect the drive and using Gparted you should be able to see it as an unpartitioned drive.  No need to do anything to it now.  The trick is to now reboot (without powering off) and swap to the MHDD boot CD.  You should notice that the drive now shows up in BIOS which is good for a start:)

Once in MHDD you can select the drive by typing in the drive number from the list.
Then hit F2 to see the drive info if you want.
Then type in .PUIS to run the script.
Then you just need to type 1 to accept and it will spin up the drive and reset the PUIS setting:)

Then shutdown (full power off computer) and turn on again to check that the drive now spins up and identifies in BIOS:)

HINT:  To make life easier, I used an external sata caddy and once I new the drive number could power down the caddy down and change drives, then power up and select the drive number again and run the .puis on the next drive.  Worked a treat:)

I have spent a whole day getting to the bottom of this problem and feel quite annoyed by the lack of knowledge shown by both WD and Highpoint.  I hope my post helps save a lot of time for other people with the same problem.

For info on PUIS you can check the wiki at
It seems that the highpoint controller puts the drive in to PUIS mode but can’t (or won’t) take them out again.
This little script does the business.
It is interesting to see all the drives that WD simply RMA’s and that WD doesn’t provide a solution!  They (WD and Highpoint) don’t seem to know it can be fixed!  I would have thought they could have made an automated version of this process on a bootable .iso to allow people to quickly fix the issue!!!

More keywords for searching
Drives not identified in BIOS
WD drives don’t spin up after removal from Highpoint RAID 23xx 2300 2310
WD PUIS problem
WD PM2 problem
How to reset WD PUIS

How to reset PM2

1 Like