I have a problem with this drive that is really bumming me out.  It is the WD 3TB Green drive that went on sale at newegg a couple of weeks ago.  My system specs are as followed (although I think the drive is the problem):

Core i7 2600k (stock speed)

ASUS P8P67 PRO (with three sata controllers, raid: Intel P67 Express Chipset, 2 SATA 6.0Gb/s, 4 SATA 3.0Gb/s, Marvell PCIe SATA 6.0 Gb/s, and JMicron JMB362 2 eSATA 3.0Gb/s)


Corsair Vengeance 2x4GB 1600

From the beginning:

Got the drive in the mail, plugged it into the JMicron port and transferred all of my data. Formatted with GPT so I could get the full drive capacity as a partition (apparently I would have to split it at 2.3TB if I used MBR), also quick format.  So I turn off the comp, switch the drive to one of the Intel P67 ports (not sure whether this was 6.0 or 3.0), and turn it back on.  Half the data was corrupted and inaccessable (Indexing errors).  So I run Chkdsk to re-index orphaned files, boot it back up, and then I click a movie and music plays, so the indexing failed big time.  Then I decide screw this, and run a full long format GPT again (took like 8 hours…), restart and the partition is missing, and there is 750GB of unallocated space (instead of the 2.73TB).

So I decide to RMA and cut my losses.  New one just came in and is giving me the same problems.  Fill it up (by the way I lost everything from the first drive so I had to re-download all of it),  get some indexing errors, restart, and the partition is gone (YOU NEED TO FORMAT THIS DRIVE TO SEE WHAT’S INSIDE LOL).

And I’m stuck now, I really don’t believe it is the raid controllers… or rather, don’t want to believe it is.  I tried it with 2/3 of them, and then got my external USB dock out and it showed me the same thing.  So I’m at a dead end, are there any suggestions anyone can give me?  I’m about to just return this drive for a refund and never get anything above 2TB again because GPT is new to me and that’s the only thing about this drive that is different from my others (WD Green 1TB, WD Green 750GB, 2x WD Black 1TB).

Thanks Guys

Forgot to mention that I did use the WD diagnostics on it and it passed everything.

Maybe you should try contacting WD’s Technical Support about this. You can do so either by phone or email.

To Contact WD for Technical Support