WD2GO webpage & Apps not able to access to NAS due to Dynamic DNS (WD2GO) problem

Hi All,

I encouter the following problem:

The WD2GO webpage indicated NAS connected, but not able to access.  I’m not able to use the WD2GO application to connect to my NAS as well.

Further check, the WD2GO webpage is the previous Public IP.  I believe the problem is related to the WD’s Dynamic DNS (for the NAS) which is still referring to the previous Public IP instead of the lastest Public IP; because when I ping the mybooklive.device######.wd2go.com, the reply IP address was different public IP from my current one (which I belive it was my previous public IP).

I’m already using the latest firmware (MyBookLive 02.11.12-060 : Core F/W), I managed to upgrade to the latest firmware before the firmware is being pulled-out by WD.

I tried to disconnected the NAS network cable (wait for 20 mins) and reconnect it, however the MBL still shown as “Connected.  Port forwarding connection established”, and the WD2GO Dynamic DNS still refering to previous Public IP.

Is there any way or script that able to force the update of the WD2GO Dynamic DNS (let say every hour, or every 30mins)?  I really hope WD will resolve the problem when the new firmware is release again!



Did you tried using another web browser or pressing the reset button on the back for 4 seconds? 

I had used another browser to test, it failed.  That’s why I check whether the WD2GO Dynamic DNS getting the correct IP or not, when I ping using the WD2GO Dynamic DNS, the Public IP being return is different from my current Public IP.

FYI, I’m not using static IP, the Public IP will be renew every 72 hours (I notice it may obtain different Public IP some times).  Beside, I normally will power off my router & WD MBL as well, so the next day when I power on the router, the Public IP address that the router getting will be a different Public IP compare to yesterday.  This is what happen when the MYBL failed to update the WD2GO Dynamic DNS to refresh the current public DNS that obtain by my router.

I saw some of the thread in this forum mentioned about this problem, and the only way to resolve it currently seems to disable the remote access, and re-enable it again (you may need to renable all the users access again).  It will be troubleshoot to redo all the setting just because of change of Public IP, where the WD2GO Dymanic DNS doesn’t able to update it.  

I believe the Dynamic DNS client (currently in the market, such as DynDNS, No-IP) is able to update / refresh when it compare the public IP in their Dymanic DNS server is different from the current Public IP that the device is connecting; or at least it will get the current Public IP address, and update to their DNS periodically (like 15mins to 30 mins interval).

Most router able to do the job as well, which work fine for FTP services.  How comes not for WD2GO?



It may not be the WD dynamic DNS. It might be your DNS provider not obeying the TTL value WD assigns for the A record / alias.

So far I’m using the NO-IP free Dynamic DNS, I follow the script to update the no-ip DNS server in the MBL. It working great. The NO-IP records updated within few seconds.

Like what being pointed out by some of the previous threads here, the MBL remote access did not update the WD2GO DNS, where one of the owner tried to monitor the network traffic, but waited so long, but still not being updated.

Any idea how to trigger the update on the WD2GO DNS?