Wd2go & WDPhoto - Device Offline Problems

Hi, please help…I have searched the community but don’t seem to be able to find an answer to this particular problem.

Quite simply I have a WD Mybook Live 2tb. I also have an iPhone with the wd2go & Wd Photos apps installed. I find these apps very useful, BUT very intermittent in how they work.

A lot of the time when I am away from home and try to access either of these apps via the 3G network I seem to get the following message, “Device Offline - This Device is Inaccessible; only local files are available”

This can be annoying as I’d like to be able to access my music and videos when away from home.

If I am at home and I try to connect via 3G and I get the error, if I then connect to my wifi network via phone, then try to connect it seems to wake the device up.

Can anyone solve this annoying little problem for me please?

Also I am fully up to date with all software and firmware.
Many thanks, Lyndon.

I have the same problem which started after I updated my firmware last night to: 02.32.05-046. I was reluctant to update the firmware for this reason and of course now I’m not able to access through the WD2go app, which displays the, “Device offline, drive inaccessible …” message. I also use the WD Photos app which is accessible but does not show the most recently saved photos. 

Anybody any ideas what causes this problem and how to fix it…it’s almost like my live book shuts down to standby and won’t switch back on via my phone on 3G! If I get back home and try to connect via wifi on my phone it seems to deactivate it!

Any ideas would be appreciated as its done this for some time, in fact since I’ve owned it about 12 months ago so not a recent problem with firmware.

the same problem here, i upgraded the firmware this weekend and now wd 2go says “devide offline”, it works at home but not on my office (using wifi)

Same problem here as well. WD 2go and WD photo connects over the home wifi network with no problem. When over 3G I consistantly get the annoying device offline message. I’ve even tried reinstalling the apps several times. I happened across an undisclosed settings page on the startup screens for both apps by tapping several times and selected “none” for the security setting and I was able to see my folders over 3G. Not sure what risk I have now with this setting set to none but it works. Can someone at WD explain this?


Who ever is having offline issues connecting outside home, can you please rename your NAS and try accessing it again.




I have the similar problem: app works when I’m on my home network but not on any other network og 3G where I get the message “Device offline”.

I have a 3TB MyBookLive and try to connect via an iPhone 4S.

I have tried to rename my nas - did not change anything.



Could you please call WD customer support? We will be happy to troubleshoot the issue?



We sure would like someone to come up with an answer to this.

Seems to be a very common problem all through this forum.

I know a couple of people personally who are waiting for a fix.

In a nutshell…access works great when you are on your local network.

Leave you network (friends wirelesss network or 3g) and you no longer have access.

You get this message:

“Device Offline - This device is Inaccessible; only local files are available”

Have tried port forwarding, no port forwarding, reinstalling software, security settings, etc but to no avail!

Please help!

… that’s because you’re not going to see thousands of people log in and say “It’s working normally.” ;) 

Keep in mind that most posts on forums are from people having issues, and that shouldn’t be interpreted as a sign of a major problem.

At any rate, log into your MBL’s webpage, Go to Settings / Remote Access.

Make sure the Connection Status says “CONNECTED.”

If it doesn’t, there’s the issue.

They must of check that it says connected thats obvious! I also get the issue since the f/w update to xxx.46 (mybooklive 1 & 2TB) I completed an RMA twice to sort with all of which failed to connect remotly. I suspect there is a bug in the firmware?

Did anyone test the renaming of the drive, any luck?

I was getting the same error but I have fixed it by opening the TCP port 80 and 443 in my router.

First check the ports you need to open.

point your browser to http://mybooklive/UI

Then, Settings>Network > Remote Access

Then from the Remote Access Page click on “Mobile Access” Tab in the middle of the page.

Make a note of the Public and private ports and the Internal IP address.

Now go to your router setup page (generally its

Log in to your router and go to “Virtual Server”

(I have a D-Link router and “Virtual Server” is the place where you generally open the port. If you have a different router it may be named differently. Whatever the name, it should show you “Private Port” and “Public Port”)

Now enter the port and IP address that you noted down and click Save. Thats IT :slight_smile:


I have tried what you describe (netgear route) but no luck, I tried opening firewall ports, port forwarding and port triggering but no luck. It was working before the firmware update via relay connection, but it seems that is no longer possbie.

Any ideas how to force it into a relay conection?

OK i figured out how to fix it…

Disable UPnP on the router, allows the remote access to work! I am guessing this forces relay mode which was what i was on proir to the Update to xx.46. It appears the xx.46 update did not resolve the issues with relay connections.

I called WD Support and we were able to resolve my problem by accessing the MyBookLive settings section via my web browser and removing all of the devices from the Settings/Remote Access/Mobile Devices section then re-adding them. I can now access both the WD Photos & WD 2go apps from my iPhone and work & home iPads. I have only tried using my home network right now so I have to wait to check if I can still access using my iPhone when I’m not using my home WiFi. I hope this helps some of you out there who have been dealing with this issue.

Well then at least there is good news for me… I’m not the only one with this problem.

I bought the My Book Live (3GB) yesterday and spent about an hour making sure I it was all up properly. Even read all the instructions to the letter. Tested it at home, worked fine. Discovered easily, added photos from my iPhone and iPad easily. From inside the home on both the 3G service and Wifi I had no problems, but who wants to really share a photo that is on their computer and display it on the ir iPhone. I bought this so that when I’m away on holidays I can send the photos and videos to my home cloud and have them as a back up. But of course like everyone else here, when I walk out the door and connect to another network I get the message that it is not indescoverable.

It’s like the ‘WD My Book Live’ just saw me leave the house and decided I didn’t need it anymore and just went to sleep.

I don’t know if anyone here has got any new ideas about solving this problem, but I sure hope that WD reads these forums because the more I look the more this sounds like a ‘common’ problem.

Add me to the list please. :cry:

Access from all computers and devices (iPad and iPhone) work great while on my local network. Once I leave my network, I get the Device offline and not accessible message.

I have tried renaming the NAS, resetting the unit, rebooting the unit, delete and re-add mobile and web user accounts, deleting and reinstalling iOS apps (WD2GO and WD Photo).

At first I had an Apple Airport Extreme and it was connecting (slowly) with a relay connection. Having read there is a compatibility problem with the Apple router, I bought a Netgear R6300. uPnP is enabled and Remote Connection is now “Connected”. My router’s UI even shows my NAS as connected and uPnP “active”. 

Here is everything I can think of that I have done:

  1. Reset the MBL Duo using the button in the back

  2. Rebooted the MBL Duo

  3. Changed the name of the NAS (three times)

  4. Deleted all mobile and web accounts, disabled remote access, enabled remote access, added back a mobile and web account. (Neither worked out of local network )

  5. uPnP is enabled and active on the router

  6. I have assigned my MBL Duo a static IP

  7. Have tried opening ports 80 and 443 manually

  8. Used the nslookup command from my local network and was returned:

    Server: UnKnown

    Non-authoritative answer:
    Name: NAS-HENDERSON.deviceXXXXXX.wd2go.com
    Address: XX.XXX.XX.XXX

 The second address is the same as my network’s external IP. 

  1. Firmware is up to date: 02.40.06-048

I am at a loss. At this point, I have no idea if it’s my network/settings or something in the firmware that is out of my control. I just purchased this unit at the end of December and have been working to get it to function properly for a month now. 

I really hope this is my error so I can fix it, but so far…no dice. 

Also, I would like to add that disabling uPnP to force a relayed connection and denying all the other devices on my local network uPnP is not an acceptable answer. 

Anyone? Western Digital? 

I emailed support almost a week ago and have heard nothing. :( 


What happens if you use a browser on the external network to browse to that hostname manually?

Do you get a response of any sort?

Just tried that and here is what was returned. 


What do you make of this? Also, thanks for the reply!