WD2go Remote Access shows MyBook Live is offline

Remote Access is enabled, but the connectivity status in the user interface stays:

Connectivity Status: Connecting

Trying to establish a remote access connection…

I have received the remote access e-Mail and can access via password. I can see MyBookLive but the status says: Offline.
MyBookLive is connected to the wireless router via Ethernet . I can access Mybook Live with all other Wireless network devices in the network.

I can access the drive via Ping an via Browser (IP).

Any idea?

Thanks a lot,


StefanZweig, maybe you should try contacting WD’s Technical Support about this. You can do so either by phone or email.

To Contact WD for Technical Support


Try disabling Remote access, then enabling it (wait a few minutes between steps). See if that does anything.

You might want to check your router as well.

Tony, thanks a lot! That solved the issue. Many, many thanks!

I am seeing the same “MyBookLive is currently offline” message after logging in successfully with my email and password. I have tried “disabling” and “enabling” remote access (waiting for a few minutes in between)  from the Dashboard but that didn’t fix the problem.

Tried port forwarding as suggested in one of the posts for my Remote Access problem where I keep getting “MyNBookLive is offline” . This did not reolve my problem.

By the way, I am using a D-Link DSL-2730B router.

i have been fighting this for a while now.  anyone want to give a step by step on setting up the router side of things? maybe i have missed something there. 

any help would be awesome


Under the remote access tab in the MBL page, what does the status say? The first post indicated their setting was ‘Connecting’ which means it was having trouble accessing the external world.