WD2go remote access fails repeatedly

Hi,

I have yet not managed to connect to my My Book Live 3TB remotely via WD2go.com. I can sign in and find my external drive there. Once i click it I get to the admin login, I type the password, I see the java plugin load for a couple of seconds, but then… The screen darkens, the “java wheel” disappears and nothing appears other than the mouse’s “hourglass”. Nothing happens for hours…

Self check:

  • I have tried to access on 3 different computers (both PCs, Win7 and a Mac, Lion)

  • I have reinstalled java

  • I have given the applet permission to mount the drive

  • Tried 3 different browsers (IE9, Chrome, Safari)

  • Remote access has been setup on the device

  • Everything else (apps, drive on home network etc) works fine

I’d be very grateful for any help on this!

Cheers

Sune1, maybe you should try contacting WD’s Technical Support about this. You can do so either by phone or email.

To Contact WD for Technical Support
http://support.wdc.com/contact/index.asp?lang=en

Regards,

it appears that you can execute the java applet. What it sounds like is that you are using  windows 7/vista and UAC dialog is asking for permission to execute the a registry update file we need to run the first time the app is launched.  Can you  see if a new program appears on your windows task bar?  If so, just click on that icon and grant permission by clicking “Yes”.

Hi,

Sorry to say that this isn’t the issue. I have granted permission on all computers I have used and even turned UAC off on the PCs. The java applet actually loads, but then when the load bar is filled and I expect to see the shares  (it says Shares (1) ) all turns dark and nothing else happens.

Just the same things happens on any of the laptops (PC, Mac) and any browser (IE9, Safari, Chrome). It seems as if the problem somehow has to do with the actual My Book Live…

Screen dump WD-issue.jpg

Are you on the latest firmware? (please post your firmware version).

OSX Lion does not install Java by default. You have to install it yourself if you want Java to work on your Mac.

Can we see a screenshot of your error?

Can you add &debug=true to the end of the applet page, and then note if there is any exceptions in the java console?

Ie:

                https://Mydevice.deviceMynumber.wd2go.com/Admin/webapp/htdocs/mapDrive.php?..&debug=true

Description:My Book Live Firmware

Version:MyBookLive 02.02.02-020 : Core F/W

Last Update:Fri 16 Sep 2011 08:34:04 AM PDT

Yes, java has been installed on the Mac I tried on.

The actual error is the screenshot above showing a that all has been stalled and nothin more happens. This is right after the java status bar has been filled and the screen changes.

Java debug, was this what you wanted to see:

createGUI didn’t successfully complete
java.lang.reflect.InvocationTargetException
 at java.awt.EventQueue.invokeAndWait(Unknown Source)
 at javax.swing.SwingUtilities.invokeAndWait(Unknown Source)
 at com.wd.nas4g.mapdrive.MapDrive.init(MapDrive.java:124)
 at sun.plugin2.applet.Plugin2Manager$AppletExecutionRunnable.run(Unknown Source)
 at java.lang.Thread.run(Unknown Source)
Caused by: java.lang.RuntimeException: Error while reading initializing messages
 at com.wd.nas4g.mapdrive.ResourceManager.init(ResourceManager.java:46)
 at com.wd.nas4g.mapdrive.MapDrive$1.run(MapDrive.java:172)
 at java.awt.event.InvocationEvent.dispatch(Unknown Source)
 at java.awt.EventQueue.dispatchEventImpl(Unknown Source)
 at java.awt.EventQueue.access$000(Unknown Source)
 at java.awt.EventQueue$1.run(Unknown Source)
 at java.awt.EventQueue$1.run(Unknown Source)
 at java.security.AccessController.doPrivileged(Native Method)
 at java.security.AccessControlContext$1.doIntersectionPrivilege(Unknown Source)
 at java.awt.EventQueue.dispatchEvent(Unknown Source)
 at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
 at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
 at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
 at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
 at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
 at java.awt.EventDispatchThread.run(Unknown Source)
Caused by: java.lang.NullPointerException
 at java.io.Reader.(Unknown Source)
 at java.io.InputStreamReader.(Unknown Source)
 at com.wd.nas4g.mapdrive.ResourceManager.init(ResourceManager.java:42)
 … 15 more

BR, S

ok - it looks like somehow the Java applet got corrupted when it was downloaded.

Can you try the following:

 Disable the  java applet cache:

  1. Go to Control Panel -> Java -> General -> Settings -> Uncheck ”keep temporary files on my computer”
  2. Restart your browser and try again
  3. If  you still gets the same error, please check to see if a file with the following pattern exists on your machine “C:\Documents and Settings[Account user name]\Local Settings\Temp\jar_cache[xxxxxxxxxxxxx]

Hmmm, still the problem exists on all three computers I have tried to access from. I have also tried reinstalling java a couple of times.

Done the 3 steps above, however no such file (nor Temp-folder) existed. And yes, the problem persists, both in IE9 and Chrome…

I really appreciate your help on this!

ok a couple other suggetions.

  1. Clear your browser cache

  2. Goto ControlPanel > java > General > Temporary Internet Files (see picture below)

  3. Delete files

  4. Uncheck “keep temporary internet files on my computer”

  5. Can you download the jar file and send it to us:

http://Mydevice.deviceMynumber.wd2go.com/Admin/webapp/htdocs/MapDrive.jar

Java settings

Did the first two parts. No changes when trying thereafter.

Now, the third part I’m not sure what to actually do. I have tried to copy and complete the URL below with my drive’s specifics, but with no luck. Could you specify in detail what I should do to access/download the jar file? Thx

 //S

In the browser,

Just type http://[url]/Admin/webapp/htdocs/MapDrive.jar

And you should be able to download the jar file.

Also, could you provide your java version and firmware version as well?

Hi,

I’ve done this, but still I only come to the page saying: “The webpage can not be displayed” or “Access denied” when trying from a browser where I have just tried to access WD2go:

https://mybooklive-device43270.wd2go.com/Admin/webapp/htdocs/mapdrive.jar

Now, on this particular laptop, I have updated to Java version 6, update 27 (build 1.6.0_27-b07)

Firmware on the MyBook:

Description:My Book Live Firmware

Version:MyBookLive 02.02.02-020 : Core F/W

Last Update:Fri 16 Sep 2011 08:34:04 AM PDT

We were able to download this jar file and it run it fine on both mac and windows.   This is likely specific to your machine.  Can you delete the java cache file?  On windows 7, it’s located at:

C:\Users[user name]\AppData\Local\Temp\jar_cachexxxxxxxxx

You need to remove any file in that pattern, and see if it helps. When I searched in my own system and saw two files that looked like :

jar_cache4535655517747570386.tmp

That is really strange. I have the same issue on all three laptops I try on so I have a really hard time thinking it has something to do with all three laptops specifically/simultaneously…

I have removed all java cache files in the temp folder but no change…

Can you try accessing the drive externally if I give you a test account (sent to your email)? In this way you will (probably experience the same issue.