WD2GO Pro iPhone - Device is not accessible?

I had my iPhone working on WD2Go and upgraded to WD2GO Pro.  Now I’m getting the message “Device Offline, The device is not accessible. Local documents are available”.  

I tried deleting pro and reinstalling the free version but I still get the message. 

On my PC, I have opened the dashboard, deleted my mobile access several times and redid the get a code step.  Still can’t get it to work.  

I can access my shares over the internet using a PC so I know the device is online. 


Hi, try pressing the reset button on the back of the MBL for 4 seconds.

Try this:

DELETE the MBL from the WD 2Go client.

DELETE the iPhone from the MBL webpage.

DISABLE Remote Access.

RE-ENABLE Remote Access.

Re-Add the device.

I know you said you did most of that already, but try the DISABLE / ENABLE step, too.

Just got MBL on Sunday, setup was easy, slow to transfer data but all good for the most part. Got the free WD 2go app for photos, didn’t work (or didn’t work easily for me) deleted it. Got the WD 2go app, again the free one. It worked at first. I could see everything and I was very impressed. Fluid and fast… Not reliable. It just stopped working saying the device is offline. I did all the steps to redo; i.e., uninstall, re-install; enable, disable etc… nothing worked. Downloaded WD 2go Pro and that didn’t work.

Called I.T. support and they stepped me through it and it worked. Great, off the phone, 15 minutes or so later and it’s not working. WTH WD…