WD2GO Pro Fundamental Flaws

  1. Some folders in the Public folder are only visible while connected via the LAN and not while connected via the WAN for no discernable reason.

  2. Clipped files can only be accessed by first connecting online to the WD drive. If you don’t have network access, you can’t access your offline files.

  3. Photos viewed using the WD2GO viewer don’t show more detail as you zoom in. If you have a photo containing text, forget about being able to zoom in and read it. This means you have to open with the Gallery which makes for cumbersome navigation between photos.

  4. Clipped files are not able to be accessed from the file system. This means that rather than simply clipping a folder, you have to open it and then save each and every file in turn before you can access them from outside of WD2GO.

  5. The “Add to Gallery” menu option when viewing a photo, doesn’t work.

I’ve only had the software for a couple of days but these problems are the most obvious ones I’ve noticed already.

All my folders are visible when I connect via Internet, using my iPad. What are you using, Android or an IOS device?

It’s Gingerbread Android on an HTC Desire S (2011 phone). It definitely looks like it is a problem with the Android WD2GO Pro software. The folders that are missing are all in the My Pictures share and contain either photos, videos or a combination of the two.

To be honest, it’s the least of my worries at the moment, the drive has been flashing the green light all afternoon and it’s virtually impossible to use the darned thing. I’ve tried rebooting it through the admin web interface but it just goes straight back to the flashing green light.

The WD2GO Pro software doesn’t work and isn’t fit for purpose.

The WD Smartware software doesn’t work and isn’t fit for purpose.

The WD My Book Live currently looks like it doesn’t work and isn’t fit for purpose.

I’ve had 3 tickets logged with support for 7 days now and the only reply I’ve had is to tell me to use a CAT6 cable!!???! If I don’t get some reasonable responses from them in the next few days I’m going to try and take it back to Comet. WD should not be able to get away with selling this junk to the public.

just want to add to the list of fundamental flaws.

I have “clipped” an entire audiobook directory and I’m expiering some issues when listening to it using wd2go Pro (v1.1 using an android phone).

  1. Playback starts over from chapter one when some files has been played. I THINK it starts over whenever  it hits the bottom of the vieable list of files from the screen you see before you enter the “player” (hard to explain without pictures). Example: if the following list of files

0801.mp3 
0802.mp3
0803.mp3
are visible when I start the player it will start over from 0101.mp3 when it has played 0803.mp3 (very anoing as a audiobook contains hundreds of small files and you need to find the last one played again every 10 minutes or so).

  1. Playback isn’t “paused” when I receive calls (anoing as I can’t hear what the other person is saying).

I really hope that WD will fix these “bugs”/flaws soon…

odd thing regarding wd 2go

On my Ipad I see all my shares. They have same settings. In all of them I see folders. But some folders showing no content and some of them are ok.

I tried everything and can’t understand reason for such behaviour. 

CaphWD, we have sent you a direct message requesting a troubleshooting session, since you have some unique issues.

Since the My Book Live is using the connection of whatever network it is on, it will be limited to the upload speed of that network. Your device’s connection may also play a part in accessibility if you are in a low-coverage area.

Other factors that will cause delays are if the My Book Live is using a Relay Connection or a Direct Connection. It is absolutely essential to have a Direct Connection in order to have optimal connection speeds for your setup.

If your Router does not use UPnP or has a non-standard variation of UPnP, you should setup Port Forwarding. We have an in-depth Knowledge Base article for setting this up here:

http://wdc.custhelp.com/app/answers/detail/a_id/8526

How to setup port forwarding on airport extreme?

woyo

wo-yo wrote:

How to setup port forwarding on airport extreme?

woyo

I would start by getting a new router - Apple is notorious for making their products as non-compatible as possible with non-apple products. If I remeber right the extreme does not even include the option for (proper) port forwarding.

I believe the Airport Extreme also doesn’t support UPnP. It hasn’t in the past.

I have a folder, and several folders with data inside it. It contains different file types (.doc, .ai, .jpg, .xls, and lots of sub folders) which I’ve been collecting during years in my notebook. There’s one particular folder which keeps being showed as empty when I try to acces it through WD2Go Pro (when I’m in my wifi network or if I’m away through the Internet, is the same issue) If I acces it from my Mac, I can see what’s inside. But from the iPhone and iPad apps looks like it is empty. I tried creating another folder, and moving all the content from the original folder to the new one, and still the same thing is happening. I run the latest OS both in iPhone as in iPad. The WD is configured with 5 users with password, and one public user. This issue is occurring in my user, which is password protected. Oddly, this is the folder were I have all my files I need to work. The other ones, containing photos, music, and other file types too, etc., they all work fine… I really need help. I can’t work!!! I’m carrying another HD with me to do what I was supposed to do through my personal cloud! Thanks!