WD2GO iOS, send as link = impossible to download

Hello everyone

Sorry for any mistake ; English’s not my mother language… :slight_smile:

I have a My Book Live 2to.
I also have an iPad and an iPhone, both have WD2GO installed, the apps run pretty smooth (though it’s hard to stream a movie, but that’s another problem), no problem to access the drive and files.

BUT, because there has to be a BUT (sad smiley) : the most important feature of WD2GO on iOS, for me, is the possibility to send a download link to an email for any file of the remote drive, and my problem is that I can send the links, but the links never work…
Tried on Chrome and Firefox, apparently (though I’m not certain of that) the “server” is unreachable or doesn’t respond.
Of course, remote access and all options are ON on the dashboard.

Does anyone know what the problem could be?

Thanks a million in advance for your help!


Hi, check if you have any firewalls that might be blocking access to the my book. 

Sorry for such a long delay ; I ALSO had problems with my Internet connexion and couldn’t move on.
Thanks a lot for your answer.

It turns out that I’m a bit stupid, because my problem was probably not a problem : the links are impossible to download locally, but apparently they can from another connexion (I tried with my 3G phone and it seemed to work)…

Thanks again for your help!

(now I have to solve the iTunes server that won’t install issue! :smiley: )