Wd2Go Down again?!?

Before I left the house this morning I made sure I logged into the dashboard and checked to ensure it was connected to WD2GO. It said it was.

Now I cannot access it my apps or the desktop client.

I can access other resources on my network from the outside, but not the MyCloud.

This seems to be a weekly occurance almost.

When I use my Andoid WD Photo app it errors “No internet connection available”.

Sort of a generic error message, does it mean that my phone cannot access the internet (Which it can), is WD2GO cannot access the internet (which i doubt) or it cannot access my MyCloud (which I can access my other network devices behind my firewall)

I just tried wd2go.com and did not have any problem with it.


Last week I had my TWC internet service go offline for a short time. I can’t blame Western Digital for that.


During a thunderstorm last week over 3,000 customers in the city where I live lost power. If any of them have and were trying to use their My Cloud device they were out of luck, however they too can’t blame that on Western Digital.


Try connecting to wd2go.com and see what happens.


Edited: It is now 3:25 PM CDST and I was just out getting something cold to drink and tried out my cell phone apps. I was able to use and see photos using the WD Photo app but I was not able to connect using the WD My Cloud app.


Posted by,
cat0w (USA)




I went to WD2GO.com and it couldn’t access my device. I could access the device before I left for work in the morning, I could access my IP cameras at my house too when at work.

I just had my wife unplug the drive, wait 20 seconds and plug it back in. I can access it again. Though when I looked at the dashboard this morning, it said it was connected properly etc.

After I switch off    drive sleep  - all problem gone…  :-)

SETTINS >> Energy Saver  >>  Drive Sleep >> OFF